Table of Contents

Chapter 1: Introduction .................................................................................................................. 1
  Features of the TE Client ............................................................................................................. 1
  About This Guide .......................................................................................................................... 2

Chapter 2: Installation and Licensing .......................................................................................... 4
  Configuring and Deploying the TE Client .................................................................................... 4
    Using Avalanche to Configure the TE Client ........................................................................... 6
    Using Avalanche to Deploy the TE Client and Configuration .................................................. 7
    Using ActiveSync to Configure and Deploy the TE Client ....................................................... 8
  Exporting and Importing Settings ............................................................................................... 9
  Licensing the TE Client .............................................................................................................. 10
  Types of Licenses ..................................................................................................................... 10
  Licensing Methods .................................................................................................................... 11
    Manually Licensing the TE Client ........................................................................................... 11
    Using the License Server to License the TE Client ................................................................. 12
    Using Demo Mode .................................................................................................................. 13
  Configuring the License Server Address ................................................................................... 14

Chapter 3: Configuring Host Profiles .......................................................................................... 15
  Adding or Modifying a Host Profile ........................................................................................... 16
  Host Profile Configuration Options ............................................................................................ 17
    Host Tab .................................................................................................................................. 18
    TermProxy Tabs ....................................................................................................................... 20
    IBM Settings Tab ..................................................................................................................... 21
    VT Settings Tab ....................................................................................................................... 22
    HTTP or HTTPS Proxy Tabs ...................................................................................................... 22
    Access List Tab ........................................................................................................................ 22
    Autologin Settings .................................................................................................................... 23
    AutoLaunch Tab ....................................................................................................................... 24
    Configuration Tab .................................................................................................................... 25
    Language Tab ........................................................................................................................... 25
    Modem Tab ................................................................................................................................ 25
    Subnet-Specific Addresses ....................................................................................................... 29
  Host Profiles and SSL/TLS .......................................................................................................... 30
    Installing the SSL/TLS Support Utility on the Host System .................................................... 30
    Installing the SSL/TLS Support Package on the Client ............................................................ 30
    Enabling SSL/TLS .................................................................................................................... 31
  Host Profiles and Wavelink ConnectPro or TermProxy .............................................................. 34
    Configuring a ConnectPro- or TermProxy-Only Host Profile ................................................... 34
    Configuring ConnectPro/TermProxy Failover ......................................................................... 35

Chapter 4: Emulation Parameters ............................................................................................... 37
  Using the Configuration Manager with Avalanche ...................................................................... 38
Using the Configuration Manager with Microsoft ActiveSync .................................................. 40

Chapter 5: Scripting .................................................................................................................. 43
Overview of Scripting .................................................................................................................. 43
Launching the Script Editor ........................................................................................................ 44
Creating Scripts Using the Script Editor .................................................................................. 45
  Selecting the Activation Method ............................................................................................... 46
  Creating Variables .................................................................................................................... 47
  Selecting Host Profiles ............................................................................................................. 48
Performing Script Capturing ........................................................................................................ 48
Editing Scripts ............................................................................................................................... 51
Importing Scripts .......................................................................................................................... 51
Saving and Exporting Scripts ....................................................................................................... 52
Deploying Scripts .......................................................................................................................... 53
Executing Scripts .......................................................................................................................... 53
  Select from Menu ....................................................................................................................... 53
  From Another Script .................................................................................................................... 54
  On Key Combination .................................................................................................................. 54
  When Session Connects ............................................................................................................. 54
  On Barcode, MSR, or RFID Scan ............................................................................................... 55
  On Screen Update ....................................................................................................................... 56
  From the Screen Reformatter ..................................................................................................... 56
  From Web Pages .......................................................................................................................... 57

Chapter 6: Keyboard Creator ...................................................................................................... 58
Launching the Keyboard Creator ................................................................................................. 58
Creating Keyboards ....................................................................................................................... 59
  Adding a Keyboard ...................................................................................................................... 59
  Sizing Keyboards ....................................................................................................................... 60
  Deleting Keyboards .................................................................................................................... 60
Creating and Configuring Keys ..................................................................................................... 61
  Adding a New Key ....................................................................................................................... 61
  Sizing and Positioning Keys and Rows ....................................................................................... 63
  Deleting Keys ............................................................................................................................. 64
Importing Keyboard Graphics ..................................................................................................... 64
Deploying the Keyboard to the TE Client ...................................................................................... 65

Chapter 7: Resource Editor ......................................................................................................... 66
Adding a Bitmap ............................................................................................................................. 67
Adding a Sound .............................................................................................................................. 67
Editing Files .................................................................................................................................. 68

Chapter 8: Reformatting Emulation Screens ............................................................................. 69
Performing a Screen Capture ....................................................................................................... 70
Using the Screen Reformatter ..................................................................................................... 71
Tree View ................................................................................................................. 72
Initial Screen View .................................................................................................... 72
Modified Screen View ............................................................................................... 72
Descriptive View ........................................................................................................ 73
Status Bar .................................................................................................................. 74
Tool Bar ..................................................................................................................... 75
Importing Screens ...................................................................................................... 75
Organizing Screens .................................................................................................... 76
Modifying a Screen ..................................................................................................... 77
  Renaming, Duplicating, or Deleting a Screen ............................................................ 77
  Copying Text .............................................................................................................. 77
  Adding Text to the Modified Screen ........................................................................ 79
  Changing the Font Size ............................................................................................. 79
  Resizing the Screen ................................................................................................. 80
  Changing the Background Color of the Screen ......................................................... 81
  Assigning an Initial Field Value ............................................................................... 81
  Creating Screen Comments ..................................................................................... 82
  Using Screen Templates ............................................................................................ 82
Verifying a Screen ........................................................................................................ 83
  Adding Host Profile Verification .............................................................................. 84
  Adding Text Verification ............................................................................................ 84
  Adding Cursor Verification ....................................................................................... 85
  Adding Field Verification ......................................................................................... 85
  Adding Persistent Variable Verification .................................................................. 85
  Ordering or Deleting Verification Items ................................................................... 86
Speakeasy and Scripting Support .............................................................................. 87
  Adding Text-to-Speech Support ............................................................................... 87
  Adding Speech-to-Text in the Reformatter ............................................................... 88
  Adding Scripting Support ......................................................................................... 94
  Ordering Screen Actions ........................................................................................... 95
Deploying Reformatted Screens .............................................................................. 96
Exporting Screens ....................................................................................................... 96
  Exporting a Master File ............................................................................................. 96
  Exporting a Screen Capture File .............................................................................. 97

Chapter 9: Using the TE Client .................................................................................. 98
  Launching the TE Client ............................................................................................ 98
  Creating an Emulation Session ................................................................................ 101
  Initiating an Emulation Session .............................................................................. 101
  Disconnecting an Emulation Session ....................................................................... 102
  Working with Multiple Concurrent Emulation Sessions ........................................ 103
  Allowing Multiple Concurrent Sessions .................................................................. 103
  Initiating an Additional Emulation Session ............................................................ 104
  Switching Between Active Emulation Sessions ..................................................... 105
Beeps Settings ................................................................. 140
Telnet Settings ................................................................. 140
Printer Settings ................................................................. 141

**Common Configuration Tasks** ............................................. 143
  Configuring Passwords ....................................................... 143
  Configuring Printing On a Network ....................................... 144
  Configuring TE Client Display Settings .................................. 145
  Configuring TE Client Lockdown .......................................... 146
  Configuring Key Macros ..................................................... 147
  Configuring Screen Panning ............................................... 149
  Configuring ActiveText ..................................................... 150
  Configuring Scan Handlers ................................................ 151
  Configuring Autologin for VT Emulation .............................. 152
  Configuring Telnet Negotiation Strings for VT Emulation .......... 153
  Configuring Workstation IDs for 5250/3270 Emulation ............. 154
  Enabling Battery Strength and Signal Strength Icons ............... 155
Chapter 1: Introduction

The TE Client is an application installed on a mobile device or desktop computer that connects to IBM 5250/3270, VT100/220, XTERM, HP, and WEB hosts. The Client connects to applications on the remote host and emulates the terminal. The Client uses Telnet, SSH, SSL/TLS, HTTP, or HTTPS to connect to an emulation host.

This section contains the following information:

- Features of the TE Client
- About This Guide

Features of the TE Client

The TE Client has several features designed to make it more functional and easy to use. Some of the most noticeable features include:

Host Profiles and Emulation Parameters. The Client uses host profiles to configure how the device contacts the emulation host. The Client allows up to four emulation sessions concurrently. The behavior of the Client during a session is configured using emulation parameters. Emulation parameters include options for sending information to a printer, configuring display settings, device lockdown, key macros, screen panning, using ActiveText and scan handlers, and configuring autologins and negotiation strings.

Keyboard Creator. The keyboard creator allows you to create a custom virtual keyboard to use during an emulation session. Additionally, import your own graphic files (bitmaps) to create unique buttons for the keyboard.

Screen Reformatter. The screen reformatter allows you to redesign how the emulation screen is displayed on the mobile device. Include only the text or options you want to be available to the user. You can also add other text or scripting and Speakeasy actions for each screen.

Scripting. Custom scripts can be incorporated into an emulation session. You can record scripts or use the Script Editor to write them. Scripts can be started when the session connects or the screen refreshes, from a menu, or by a specific key combination or when a scan is processed. You can also incorporate them into the screen reformatter to run with specific screens.

Speakeasy. Speakeasy is an optional component of Terminal Emulation that can turn text to speech or process spoken commands and output text on the mobile device. Speakeasy is licensed and installed separately.

ConnectPro. The ConnectPro server is an optional component of Terminal Emulation that handles session persistence. ConnectPro acts as a proxy between the mobile device and the
emulation host. If the device loses connectivity or goes to sleep, the ConnectPro server maintains the session until the device reconnects. ConnectPro is free with Terminal Emulation but is installed separately.

**License Server.** The License Server is an optional component of Terminal Emulation that handles licensing for TE Clients. It distributes licenses wirelessly and tracks licenses that haven’t been used recently if you need to redistribute your licenses. The License Server is free with Terminal Emulation but is installed separately.

**WEB emulation.** The TE Client includes an Industrial Browser interface that gives you the ability to access web-based applications from a mobile device. Develop your own web pages using META tags and IDA commands to enable specific functionality in the Industrial Browser. The Industrial Browser is supported PocketPC 2003, Windows Mobile 5.0, Windows 2000/XP, and Windows CE .NET 4.2/5.0.

**Avalanche integration.** If you use Wavelink Avalanche in connection with the TE Client, Avalanche provides a session monitor. The session monitor includes an override feature that allows you to take control of the TE Client. It also includes a logging feature that allows you to create a trace for emulation sessions. Avalanche also retrieves real-time statistics from the Client so you can view them at the Console.

## About This Guide

This guide assumes that the reader has the following:

- Familiarity with Windows CE operating systems and the mobile device to which you are deploying the Wavelink TE Client.
- Knowledge of wireless networks and wireless networking protocols (IEEE 802.11b).
- Knowledge of TCP/IP, including IP addressing, subnet masks, routing, BOOTP/DHCP, WINS, and DNS.
- Knowledge of Telnet services and terminal emulation, including IBM 5250/3270, HP, and VT100/220.
- Knowledge of Wavelink Avalanche and Avalanche Enablers (for users that intend to install and configure the TE Client via Avalanche).
- Knowledge of Microsoft ActiveSync (for users that intend to install and configure the TE Client using ActiveSync).

The following table lists the document conventions used in this manual.
Any time you type specific information into a text box (such as a file name), that option appears in the **Courier New** text style. This text style is also used for any keyboard commands that you might need to press.

Examples:

Type *Enter* to continue.

Press `CTRL+ALT+DELETE`.

**Bold** Any time you interact with an option (such as a button or descriptions of different options in a dialog box), that option appears in the **Bold** text style.

Example:

Click **File > Open**.

**Italic** Any time this document refers another document to the titles of dialog boxes.

Example:

The *Script Editor* dialog box appears.

For concision and clarity, the term Avalanche Console used in this manual applies to both Avalanche MC and Avalanche SE. For more information about each product, see the specific user guide.
Chapter 2: Installation and Licensing

The TE Client must be configured and installed on a mobile device before you can use it for emulation. It also needs to be licensed before you can use it with full functionality.

The TE Client is configured to automatically re-install in the event of a cold boot. The cold boot recovery process ensures that both the TE Client application and configuration survive the cold boot.

NOTE: The Generic TE Client will not survive a cold boot.

To allow the TE Client to survive a cold boot, a backup copy of the Client is stored in the non-volatile Flash memory of the device. A copy of any configuration files for the Client are also stored in this location.

Cold boot recovery processes vary across mobile devices. Each Client uses the recovery method of the mobile device for which it has been designed.

This section provides the following information:

- Configuring and Deploying the TE Client
- Licensing the TE Client

Configuring and Deploying the TE Client

The TE Client is configured and installed using one of the following methods:

- **Wavelink Avalanche.** If your mobile device is running the Avalanche Enabler, you can use Avalanche to deploy the TE Client and Client configurations to a mobile device.

- **Microsoft ActiveSync.** You can install the TE Client configuration utility on a host PC. The configuration utility uses an ActiveSync connection between the host PC and the mobile device to deploy the Client and configurations to the mobile device.

- **Third-Party Applications.** Wavelink supports some third-party deployment applications. For more information about supported deployments for your device, please see the Wavelink Web site. If you choose to use a third-party application to configure and install the TE Client, please see the documentation for that application for details on this process.

Depending on the TE Client installation and configuration utility that you are using, some tools that allow you to configure TE Client features may not be available. Tools for configuration may include the following:
Chapter 2: Installation and Licensing

Host Profiles A host profile contains all of the required information for a mobile device to connect to a host system, including an alias, IP address, TCP port, and other emulation-specific parameters. The TE Client supports multiple host profiles to allow a user at the device to easily create emulation sessions with various host systems. For information on the options available for a host profile, see Configuring Host Profiles on page 15.

Emulation Parameters Emulation parameters provide control over many aspects of an emulation session, including key macros, text and screen display, and barcode scanning. You may control the settings of an emulation session on a global level or on a per-host level. For information on setting emulation parameters, see Emulation Parameters on page 37.

Script Editor You can automate actions for the TE Client using scripting. For example, you might create a login script for users. You may record scripts, or you may use the Script Editor to create new scripts or modify existing scripts. For information on creating scripts for the TE Client, see Scripting on page 43.

Screen Reformatter The Screen Reformatter (included in TE Client 7.1 and later versions) is an application that allows you to modify the appearance of TE Client emulation screens. You can create a screen layout that includes items you want the mobile device user to see, and does not include items that should not be visible to the user.

Keyboard Creator Use the Terminal Emulation Keyboard Creator to modify the standard TE Client virtual keyboards to meet the needs of your production environment. The Keyboard Creator allows you to completely modify the layout of the virtual keyboard for each emulation type. Additionally, import your own graphic files (bitmaps) to create your own unique buttons for the keyboard.

Resource Editor The Resource Editor allows you to deploy graphic and sound files to your mobile devices. You may add, modify and deploy any .bmp or .wav file using the Resource Editor.

Localization Localization allows you to convert strings of text from one language to another. Use the Localization tool to create conversions, then configure the TE Client to use the appropriate language. For example, you might create support files to convert server strings from English to Spanish.

Import/Export Settings If you have already configured a TE Client and you want to use that configuration for other Clients, you can import or export settings.

This section includes information on using the following configuration/installation options:
Using Avalanche to Configure the TE Client

You can use the Avalanche Console to update the TE Client configuration.

To configure the TE Client through Avalanche:

1. Ensure that the TE Client Avalanche package has been added to an Avalanche software profile.
2. Launch the Avalanche Console.
3. In the Profiles tab, locate the profile that contains the TE Client package.
4. In the Software Packages tab, select the TE Client software package and click Configure.

The Configure Software Package dialog box appears.
5 From the menu list, select the configuration tool that you want to use.

6 Edit the configuration options as desired.

7 After you have configured the new settings for the TE Client, use the Avalanche Console to deploy the new configuration to the mobile device.

Using Avalanche to Deploy the TE Client and Configuration

After you have configured the TE Client, deploy the configuration (and the Client, if it is not yet installed).

To deploy the TE Client and/or its configuration:

1 From the Avalanche Java Console, select the Profiles tab and click the name of the software profile with the TE Client package.

2 Enable the profile and apply it to the location where you want it deployed. If desired, add selection criteria to the profile to restrict the devices it is deployed to.

3 Enable the TE Client software package.
4 If you have Auto Deploy enabled, the profile is immediately deployed to the mobile device server(s). If you need to manually deploy, you can either perform a universal deployment or right-click the server to which you are deploying and click Deploy Now in the context menu.

5 Wait for the device to update according to its schedule, or right-click a device in the Mobile Device Inventory and click Update Now. You can also update from the device by launching the Avalanche Enabler and tapping File > Connect.

Using ActiveSync to Configure and Deploy the TE Client

Use the Microsoft ActiveSync installation and configuration utility to configure host profiles, emulation parameters, and localization. After you have created the configuration, push the configuration files to the mobile device over a Microsoft ActiveSync connection between the host system and the mobile device.

To configure the TE Client using Microsoft ActiveSync:

1 Create an ActiveSync connection between the host system and the device you are deploying to. This can be a Guest or a Standard partnership.

2 Download and run the ActiveSync TE Client installation and configuration utility on the host system.

The Wavelink Product Configuration dialog box appears.

3 Click the icon buttons to open the TE Client configuration tools and configure the Client as desired.
4 Use the buttons Application & Config, Application Only, and Config Only to deploy the Client and/or its configuration to the device.

Exporting and Importing Settings

When you have different device types, you can save the settings for one device and then export them to reuse with a different device. This may include host profiles, emulation parameters, scripts, screen reformatting, custom keyboards, resources you have added using the resource editor, or localization files. This type of export compiles the selected settings into a .wltna file. Save the file where it can be accessed when you are configuring another device, then import it using either Avalanche or the ActiveSync installer.

To export settings using Avalanche:
1 From the Java Console, select the profile that has the configured TE Client package.
2 From the Software Packages area of the Software Profile tab, select the package and click Configure.
3 The Configure Software Package dialog box appears. From the available list, double-click Import/Export Settings.
4 The Import/Export Settings dialog box appears. Select either Export (save) all the current settings to a file or Export (save) selected settings to a file and click Next. If you choose to export selected settings, the Select Export Settings dialog box allows you to choose the settings you want to export.
5 The Save As dialog box appears. Specify a name for the file and where it should be saved and click Save. Once the settings have been exported, they can be imported using the same Import/Export Settings option -- just choose the Import (load) emulation settings saved in a file option.

To export settings using the ActiveSync installer:
1 From the Product Configuration dialog box, click Import/Export Settings.
2 The Import/Export Settings dialog box appears. Select either Export (save) all the current settings to a file or Export (save) selected settings to a file and click Next. If you choose to export selected settings, the Select Export Settings dialog box allows you to choose the settings you want to export.
3 The Save As dialog box appears. Specify a name for the file and where it should be saved and click Save. Once the settings have been exported, they can be imported using the same Import/Export Settings option -- just choose the Import (load) emulation settings saved in a file option.
Licensing the TE Client

The TE Client requires a license for full functionality. You can use the Client without a license, but you will be limited to the demo version without full functionality.

TE Client licensing is on a per-client basis, not on a per-connection basis. This means that a single license allows the TE Client to engage in the maximum number of emulation sessions that the TE Client is configured to support (up to four concurrent sessions).

When the TE Client does not have a valid license, it operates in demo mode. When the TE Client is operating in demo mode, it will behave as follows:

- When you attempt to initiate a terminal emulation session, the TE Client will begin broadcasting in an attempt to locate a license server. At that point, you are prompted to either enter a license or to initiate the session in demo mode.

- While in demo mode, you may initiate terminal emulation sessions with hosts. However, each terminal emulation session that you initiate will automatically disconnect after one hour.

This section contains the following information:

- Types of Licenses
- Licensing Methods
- Configuring the License Server Address

Types of Licenses

Emulation licenses are specific to an emulation type (e.g., a license can be issued for VT emulation or IBM emulation).

There are two types of TE Client licenses: platform licenses and maintenance licenses.

- **Platform licenses.** A platform (or base) license authorizes you to use a version of the TE Client and any builds associated with that version. For example, if you purchased a 8.0 TE Client license, then you are entitled to use 8.0-xx builds. If you want to upgrade beyond a version 8.0 TE Client, then you must either buy a new platform license or purchase a maintenance license. Platform licenses do not expire, but they do not allow you to upgrade to a newer version of the TE Client.

- **Maintenance licenses.** A maintenance license allows you to upgrade your TE Client when new major versions of the TE Client become available. For example, a maintenance license allows you to upgrade from TE Client 7.x to TE Client 8.x.
Maintenance licenses are valid only through a specific date. After the expiration date, if you upgrade the TE Client, it will revert to operating in demo mode.

**Licensing Methods**

There are three ways to license the TE Client:

- **Pre-licensing.** The TE Client may come pre-installed and pre-licensed on your mobile device. For pre-licensing information, please consult your mobile device manufacturer or reseller.

- **Manual licensing.** You may use the TE Client interface on the mobile device to manually input licensing information.

- **License Server.** You may use a License Server to automatically provide TE Client licenses to the mobile devices on your network.

**NOTE:** To obtain Terminal Emulation licenses, please contact Wavelink customer service.

This section provides the following information:

- Manually Licensing the TE Client
- Using the License Server to License the TE Client
- Using Demo Mode

**Manually Licensing the TE Client**

You may key in your authorization information manually through the TE Client interface on the mobile device.

**To manually license a TE Client:**

1. On the mobile device, launch the TE Client.

2. Add a license by tapping **Options > Authorization** or by attempting to establish a connection to a host. When you attempt to connect, the *Authorizing Terminal* dialog box appears. Tap **Add License**.

   The *Authorization* dialog box appears.

3. In the **Licensee Name** text box, type the name of the person or company for which the Client is licensed.

4. In the **Serial #** text box, type the serial number for the license.

5. In the **Exp. Date** text box, type the expiration date of the license, in the format of **MMDDYYYY**.

6. In the **Auth. Code** text box, type the authorization code for the license.
7 In the User # text box, enter a user number.

**NOTE:** Each TE Client should have a unique user number. The user number can be any number between 1 and the maximum number of users for which the license provides.

8 In the Limit text box, enter the maximum number of users for the license.

9 Tap **Authorize**.

The license type appears in the Platform text box.

**Using the License Server to License the TE Client**

The client license server is a Wavelink application that is responsible for supplying licenses to mobile devices that are using the TE Client.

**NOTE:** The client license server should not be confused with the Avalanche license server. They are separate Wavelink applications.

For information about installing and configuring the client license server, see the *Terminal Emulation License Server Reference Guide* on the Wavelink Web site.

When you attempt to initiate an emulation session with a host, if the TE Client is not already licensed, it will automatically attempt to obtain a license from a license server.

**To use the license server to obtain a license:**

1 When you attempt to connect to a host using the TE Client, it broadcasts a request for a license on the local IP network. Or, if you have configured the license server address, the Client sends a request to the specified license server.

**NOTE:** If the license server is not on the local network you must configure the license server IP address in order for the device to obtain a license. For more information, see **Configuring the License Server Address** on page 14.

The Authorizing Terminal dialog box displays on the mobile device while the TE Client attempts to locate a license server.

2 License servers with an available license respond by offering a license.

3 The TE Client accepts the first license that it receives and sends a reply to the license server. The Authorizing Terminal dialog box on the mobile device indicates that a license has been obtained.

If no license server responds to the request for a license, then the Authorizing Terminal dialog box continues to display until you close the dialog box, run the Client in demo mode, or choose to manually add a license.
Using Demo Mode

If you want to use the TE Client for demonstration purposes, you can run the Client in demo mode. The demonstration license automatically disconnects an emulation session after one hour.

To use the TE Client demo license:

1. Launch the TE Client.

2. Use the TE Client to initiate an emulation session with a host.
   - If you have configured the TE Client with only one host profile, the Authorizing Terminal dialog box appears.
   - If you have more than one host profile, the Select Host dialog box appears. Select the host with which you want to establish an emulation session and the Authorizing Terminal dialog box appears.

3. In the Authorizing Terminal dialog box, tap Start Demo.

The TE Client uses the demonstration license and attempts to connect to the host that you selected. Before displaying the host emulation screen, the TE Client displays a screen that indicates that you are using a demonstration license.
**Configuring the License Server Address**

A mobile device will automatically find the license server on the local subnet. However, if your license server is located on another subnet, you will need to configure the mobile device with the IP address of the license server.

To configure the IP address of a remote license server:

1. Access the Configuration Manager. For instructions on how to access the Configuration Manager, see Emulation Parameters on page 37.

2. In the Configuration Manager, locate the Emulation > Common > License Server Address parameter.

3. Use the License Server Address dialog box to configure the IP address of the license server.

4. Click OK.

5. Save the new configuration.

6. Close the Configuration Manager and download the new configuration to the mobile device.
Chapter 3: Configuring Host Profiles

A host profile defines the parameters that the TE Client should use when it attempts to initiate a connection with a specific host. The host profile may include the emulation type, IP address of the host, or other settings. You may configure an unlimited number of host profiles. Use the Host Profiles dialog box to configure host profiles.

When a user at the mobile device attempts to use the TE Client to initiate a session with a host, the TE Client displays a list of available host profiles. The user selects the host to which they wish to connect, and the TE Client uses the host profile settings to attempt to establish a session with the host.

To access the Host Profiles dialog box from the ActiveSync configuration utility:

• Click Host Profiles.

To access the Host Profiles dialog box from Avalanche:

• From the software profile, select the TE Client software package from the list and click Configure. From the list that appears, select Host Profiles and click Launch.
Each host profile that you configure appears in a list in the *Host Profiles* dialog box. Use the arrow buttons at the bottom of the list to reorder profiles in the list.

This section contains the following information on configuring host profiles:

- **Adding or Modifying a Host Profile**
- **Host Profile Configuration Options**
- **Host Profiles and SSL/TLS**
- **Host Profiles and Wavelink ConnectPro or TermProxy**

**Adding or Modifying a Host Profile**

You can use the *Host Profiles* dialog box to create a new host profile or modify an existing one.
Chapter 3: Configuring Host Profiles

NOTE: If you want to copy a host profile from one device configuration (or Avalanche package) to another, you can export it. For instructions, see Exporting and Importing Settings on page 9.

To create or modify a host profile:

1. Access the Host Profiles dialog box.

2. To create a new host profile, click New. To modify an existing host profile, select the profile from the list.

   Various tabs appear in the Host Profiles dialog box that allow you to configure the parameters for a new host profile. The tabs that appear are dependent on the type of emulation that you select for the host profile. For information about the various tabs in the Host Profiles dialog box, see Host Profile Configuration Options on page 17.

3. Use the tabs in the Host Profiles dialog box to configure the host profile.

4. If you want to delete a host profile, select it from the list and click Delete.

5. After you have finished configuring host profiles, click OK.

   The host profile configuration is saved.

6. Download the host profile configuration to the mobile device.

NOTE: For information about downloading configurations to mobile devices, see Configuring and Deploying the TE Client on page 4.

Host Profile Configuration Options

This section describes the options available in the tabs in the Host Profiles dialog box. The tabs may include:

- Host Tab
- TermProxy Tabs
- IBM Settings Tab
- VT Settings Tab
- HTTP or HTTPS Proxy Tabs
- Access List Tab
- Autologin Settings
- AutoLaunch Tab
- Configuration Tab
• Language Tab
• Modem Tab

Host Tab

Use the Host tab in the Host Profiles dialog box to configure the basic settings of the host profile. The options may vary depending on the type of emulation you have selected.

Configuring Host Settings

The following list describes the options and configurable parameters in the Host tab.

Name

The name of the host profile, which should be synonymous with the name (alias) of the host system to which the mobile device connects when the host profile is used.

Possible Values: 1 - 50 alpha-numeric characters
<table>
<thead>
<tr>
<th>Type</th>
<th>The type of emulation that the mobile device uses when connected to the host system.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Address</td>
<td>The IP address or host name of the host system to which the mobile device will connect.</td>
</tr>
<tr>
<td>Port</td>
<td>The TCP port number on which the host system is listening for emulation requests from Clients.</td>
</tr>
<tr>
<td>Only Use TermProxy Connections</td>
<td>Indicates whether the TE Client should only connect to the host through a TermProxy or ConnectPro server. If you enable this checkbox, you must configure the host information (name, IP address, emulation type, and port) and you must also configure the TermProxy 1 tab.</td>
</tr>
<tr>
<td>Use SSL/TLS Encryption</td>
<td>Indicates whether the TE Client should use SSL/TLS to connect to the host system. When you enable SSL/TLS, the port will automatically change to 992.</td>
</tr>
<tr>
<td>Verify Server Certificates</td>
<td>Indicates whether the TE Client should use certificate verification before allowing a connection to the host. If you enable certificate verification, click Select Verification Certificates to use the Certificate Manager to import trusted server certificates and/or create your own certificates.</td>
</tr>
<tr>
<td>Select Verification Certificates</td>
<td>Click this button to access the Certificate Manager, which allows you to import trusted server certificates and/or create your own server certificates for SSL/TLS certificate verification.</td>
</tr>
<tr>
<td>Use SSH encryption</td>
<td>Enable this option if you want to use SSH to encrypt the data between the ConnectPro or TermProxy server and the host. If you enable this option, the Use SSL/TLS encryption option will disable.</td>
</tr>
<tr>
<td>NOTE: Terminal Emulation supports both SSH1 and SSH2.</td>
<td></td>
</tr>
<tr>
<td>Tunnel Telnet using SSH Local Port Forwarding</td>
<td>Enable this option if you want to use a Telnet connection tunneling through a SSH server.</td>
</tr>
<tr>
<td>Address</td>
<td>Enter the IP address of the SSH host that will perform the tunneling.</td>
</tr>
<tr>
<td>Port</td>
<td>Enter the port of the SSH host that will perform the tunneling.</td>
</tr>
</tbody>
</table>
Chapter 3: Configuring Host Profiles

**TermProxy Tabs**

You may configure up to three ConnectPro / TermProxy connections. Use the TermProxy tabs to specify the parameters of the ConnectPro / TermProxy connection.

The following list describes the configurable options in the TermProxy tab:

- **TermProxy Server** Select the ConnectPro or TermProxy server to which the TE Client will connect.

  Possible Values:
  
  - **None.** Specifies no TermProxy or alternate host is used.
  
  - **Version 2.x.** Specifies TermProxy 2.x. TermProxy 2.x will accept connections from any TE Client.
  
  - **Version 3.x.** Specifies TermProxy 3.x. TermProxy 3.x will only accept connections from 5.x (or greater) TE Clients.
  
  - **Version 4.x.** Specifies TermProxy 4.x or ConnectPro.
  
  - **Alternate Telnet Host.** Specifies an alternate host system for failover purposes.

- **Address** Indicates the IP address of the proxy server or alternate host system.

- **Port** Indicates the TCP listening port of the proxy server or alternate host system.

- **Terminate TermProxy Session** Indicates when the ConnectPro or TermProxy server should terminate the connection to the host.

  Possible Values:
  
  - **Never.** The proxy server never terminates the session established with the host. The Client is responsible for terminating the session.
  
  - **On Network Error.** The proxy server terminates the session with the host when a network error occurs, such as a loss of network connectivity.
  
  - **On Session Exit.** The proxy server terminates the session with the host when the session is terminated by the Client.
  
  - **Always.** The proxy server will terminate the session with the host on a network error or when the session is terminated.
Client Reconnects if Unexpectedly Disconnected

Indicates if the Client will attempt to reconnect if the session with the proxy server is lost and the Client has not received a disconnect message from the proxy server.

Reconnect String

Specifies the reconnect string that the mobile device should use when connecting to the host. (You may also configure reconnect strings in TermProxy or ConnectPro.)

Use SSL/TLS Encryption

Specifies whether the TE Client should use SSL/TLS to connect to the proxy server or alternate Telnet host. (TermProxy 2.x does not support SSL/TLS connections.)

Verify Server Certificates

Indicates whether the TE Client should use certificate verification before allowing a connection to the host. If you enable certificate verification, click Select Verification Certificates to use the Certificate Manager to import trusted server certificates and/or create your own certificates.

Select Verification Certificates

Click this button to access the Certificate Manager, which allows you to import trusted server certificates and/or create your own server certificates for SSL/TLS certificate verification.

Use Custom encryption

Enable the Use Custom encryption option to encrypt data between the mobile device and the TermProxy/ConnectPro server.

Key

Once you enable the Use Custom encryption option, the Key text box is active. Type the password specified in the TermProxy/ConnectPro configuration in the text box.

IBM Settings Tab

Use the IBM Settings tab of the Host Profiles dialog box to configure the creation of a workstation ID for mobile devices connecting to an IBM host. The workstation ID includes static characters and the following switches, which are used to capture dynamic data that is specific to each mobile device:

- **%a - %d.** Captures specific octets of the IP address of the mobile device. For example, use %a%b%c%d to capture all four IP octets of the address of the mobile device, or use %d to capture only the last octet of the IP address of the mobile device.

- **%m - %r.** Captures specific octets of the MAC address of the mobile device. For example, use %p%q%r to capture the last three octets of the MAC address of the mobile device.

- **%s.** Captures the session number.
Chapter 3: Configuring Host Profiles

- %t. Captures the Avalanche terminal ID of the mobile device. (If the mobile device does not have an Avalanche Enabler, then this parameter is not valid.)

A workstation ID can be 1-20 alphanumeric characters plus switches, but IBM hosts usually truncate workstation IDs that are more than 10 characters. The workstation ID should not begin with a numeric character.

**NOTE:** The **IBM Settings** tab only appears you have configured the host profile for an IBM-type emulation in the **Host** tab.

**VT Settings Tab**

Use the **VT Settings** tab in the **Host Profiles** dialog box to configure a Telnet negotiation string for the host connection.

A Telnet negotiation string is used to identify a mobile device to a host system and to present a Client with the appropriate emulation options. The host system can then supply information to the mobile device based on Telnet negotiation string (for example, menus or display options). The string can be 1-20 alpha-numeric characters.

The **VT Settings** tab only appears if you have configured the host profile for VT- or HP-type emulation in the **Host** tab.

**HTTP or HTTPS Proxy Tabs**

Use the **HTTP Proxy** or **HTTPS Proxy** tab to configure proxy connections for WEB emulation.

The following list describes the options and configurable parameters in the **HTTP Proxy** tab.

- **Connection Type**
  - Indicates the type of connection for the host profile to use.
  - **Possible Values:** <Direct Connection> <Use Explorer Default> <Use Proxy Server>

- **Proxy Server**
  - Indicates the location of the proxy server.

- **Port**
  - Indicates the network port for the proxy server.

- **Do not use the proxy server when contacting local hosts**
  - Indicates whether the TE Client should use the proxy server when contacting hosts that reside on the same network.

**Access List Tab**

Use the **Access List** tab to create a list of web addresses the Client can access.

The following list describes the options in the **Access List** tab.
Allowed Web Server Addresses
Lists the web addresses that the TE Client is permitted to connect to.

Allow web servers on the local network (subnet)
Indicates whether the TE Client can connect with any web server or only with servers on the local network.

Add Address
Select this button to add a new IP or web address to the list of addresses that TE Client is permitted to connect with.

Delete Address
Select this button to delete an address in the list.

**Autologin Settings**

Use the Autologin tab in the Host Profiles dialog box to configure autologin parameters for the mobile device, such as a user name and password. This tab will present different options depending on the emulation type.

The following list describes configurable options on the Autologin tab if you are using VT/HP emulation:

<table>
<thead>
<tr>
<th>Prompts</th>
<th>CFG in Terminal</th>
<th>Responses</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Name</strong></td>
<td>Indicates the user name prompt that the host system uses.</td>
<td>Indicates whether users should configure the response to the login prompt at the mobile device.</td>
</tr>
<tr>
<td>Possible Values: 0 - 60 alpha-numeric characters</td>
<td>Possible Values: &lt;Enabled&gt; &lt;Disabled&gt;</td>
<td></td>
</tr>
<tr>
<td>Default Value: login</td>
<td></td>
<td>Possible Values: 0 - 30 alpha-numeric characters</td>
</tr>
<tr>
<td><strong>Password</strong></td>
<td>Indicates the password prompt that the host system uses.</td>
<td>Indicates whether users should configure the response to the password prompt at the mobile device.</td>
</tr>
<tr>
<td>Possible Values: 0 - 60 alpha-numeric characters</td>
<td>Possible Values: &lt;Enabled&gt; &lt;Disabled&gt;</td>
<td>Possible Values: 0 - 30 alpha-numeric characters</td>
</tr>
</tbody>
</table>
## Prompts

<table>
<thead>
<tr>
<th>Command</th>
<th>Indicates the command prompt that the host system sends to the TE Client after the login is complete.</th>
<th>Possible Values: 0 - 60 alpha-numeric characters</th>
</tr>
</thead>
</table>

| CFG in Terminal | Indicates whether users should configure the response to the command line prompt at the mobile device. | Possible Values: <Enabled> <Disabled> |

| Responses | Indicates the command that the mobile device should send the host system at the command prompt. | Possible Values: 0 - 30 alpha-numeric characters |

The following list describes configurable options on the Autologin tab if you are using IBMHOST emulation:

- **User Name**: The user name the Client should use when connecting to the host.
- **Password**: The password the Client should use when connecting to the host.
- **Program/Procedure**: A program/procedure that should run when the Client connects.
- **Menu**: The name of the menu you want displayed when the Client connects.
- **Current Library**: The name of a library the Client should navigate to when it connects.

**NOTE**: When configuring 5250 autologin for the AS/400, the `QRMTSIGN` system value must be set before the autologin will function properly. Use `WRKSYSVAL QRMTSIGN` and change the parameter to `*VERIFY`. This setting verifies that the user has access to the system, allowing the user to bypass the sign-on. The default is `*FRCSIGNON`.

### AutoLaunch Tab

Use the AutoLaunch tab in the Host Profiles dialog box to configure a host profile to automatically launch when the TE Client starts. You can configure autolaunch for one host profile for each session. Session 1 will connect when the Client starts, and the other sessions will automatically connect to the host when you switch to them.

If you want to configure more than one profile to automatically launch, you must increase the number of sessions specified in the emulation parameters. For more information, see Allowing Multiple Concurrent Sessions on page 103.

**NOTE**: Each host profile is automatically launched only once each time the Client runs.
**Configuration Tab**

Use the **Configuration** tab in the *Host Profiles* dialog box to access and configure per-host emulation parameters. Click **Modify** to open the Configuration Manager, or click **Reset** to restore the default settings for this host.

---

**NOTE:** For more information about global and per-host emulation parameters, see *Emulation Parameters* on page 37.

**Language Tab**

Use the **Language** tab in the *Host Profiles* dialog box to configure Terminal Emulation language support.

The following list describes the options in the **Language** tab:

- **Display Language** Specifies the language for the TE Client display.
- **Server Language** Specifies the language for the server.
- **Keyboard Type** Specifies the keyboard to be used.

**Modem Tab**

If the mobile device has a GPRS or modem connection, you can configure WWAN settings in a host profile. The WWAN configurations are dependent on your network environment as well as your cellular carrier.

The following list provides information about each of the settings available in the **Modem** tab. However, you may need to contact your cellular provider or network administrator for information regarding specific setup.
Connection name, or blank to not use modem

Indicates the name of the modem connection.

Leave the connection name blank if the host profile does not use a modem connection.

If the profile will be using one of the device's existing modem connections, then specify the name of that connection. Each different connection must have a unique connection name.
Overwrite this connection if it exists on the device: Indicates whether the TE Client should overwrite the connection if the connection is already on the device.
Enable this option if anything about the connection must be changed.
Disable this option if the profile will be using one of the device’s existing modem connections.

Auto-disconnect modem when all sessions end: Indicates whether the TE Client should disconnect this modem connection after all sessions that use it have ended.
This option works with GPRS connections (that have an Access Point Name) when the "Use wireless LAN if available" is disabled. This option also works with PPP connections (that use Dialing Instructions).

Use wireless LAN if available: When enabled and the device has a wireless LAN connection, the TE Client does not make the modem connection.
When disabled, the TE Client always uses the modem connection.

Select connection details: To use a GPRS service for the connection, select Access Point Name.
To use a dial-up modem connection, select Dialing Instructions.

Access Point Name (APN) or Number: If connection details are set to Access Point Name, then specify the APN.
(The name of the GPRS gateway, obtained from the cellular service provider.)
If the connection details is set to Dialing Instructions, enter the number exactly as it should be dialed.

User name: The user name to be used during authentication.

Password: The password to be used during authentication.

Domain: The domain to be used during authentication. This should be provided by the ISP or network administrator.

By clicking the Advanced button, you can access the TCP/IP Properties dialog box, which has the following options:
Chapter 3: Configuring Host Profiles

TCP/IP Properties

You can get IP settings assigned automatically if your network supports this capability. Otherwise, you need to ask your network administrator for the appropriate IP settings.

- **Obtain an IP address automatically**
- **Use the following IP address:**
  - IP address:

- **Obtain DNS server address automatically**
- **Use the following DNS server addresses:**
  - Preferred DNS server:
  - Alternate DNS server:
  - Preferred WINS server:
  - Alternate WINS server:

- **Software Compression**
- **IP Header Compression**

**Obtain an IP address automatically**
If this option is enabled, the IP address of the device is assigned by the network the device connects to.

**Use the following IP address**
If this option is enabled, the device’s IP address for the connection is specified by the IP address field.

**IP address**
This field specifies the IP address to be used while this connection is active.

**Obtain DNS server address automatically**
If this option is enabled, the connection’s DNS and WINS server addresses are assigned by the network the device connects to.

**Use the following DNS server addresses**
If this option is enabled, the connection uses the specified DNS or WINS server addresses.

**Preferred DNS server**
The IP address of the DNS server to be used while this connection is active.
Chapter 3: Configuring Host Profiles

Alternate DNS server
The IP address of a secondary or backup DNS server to be used while this connection is active.

Preferred WINS server
The IP address of the WINS server to be used while this connection is active.

Alternate WINS server
The IP address of a secondary WINS server to be used while this connection is active.

Software Compression
If this option is enabled, software compression is negotiated on the connection link.

IP Header Compression
If this option is enabled, IP header compression is negotiated on the connection link.

Subnet-Specific Addresses

When creating a host profile, you may enter a subnet-specific address rather than an IP address or a DNS name. A subnet-specific address will have the following format:

0.X.X.X/X. The specified address is combined with the mobile device IP address to determine the host’s address. The number after the slash determines the number of bits of the subnet-specific address that should be ignored. This is usually the same as the number of bits at the start of the subnet mask.

Examples:

For a mobile device with an IP address of 10.20.30.40:

- When connecting to a subnet-specific address of 0.1.2.3/8, the device will look for a host at 10.1.2.3
- When connecting to a subnet-specific address of 0.0.2.3/16, the device will look for a host at 10.20.2.3
- When connecting to a subnet-specific address of 0.0.0.3/24, the device will look for a host at 10.20.30.3

Subnet-specific addressing is also available for WEB emulation. However, you should use a | character instead of a / character to denote the number of bits.

Examples:

For a mobile device with an IP address of 10.20.30.40:

- When connecting to a subnet-specific address of
  http://0.1.2.3|8
  the device will look for a host at:
  http://10.1.2.3/
• When connecting to a subnet-specific address of
  https://0.0.0.3|24:8080/start.asp
  the device will look for a host at:
  https://10.20.30.3:8080/start.asp

Host Profiles and SSL/TLS

The TE Client supports SSL- or TLS-encrypted Telnet sessions to host servers or to a Wavelink TermProxy or ConnectPro server. The TE Client also supports certificate validation for SSL/TLS connections. For specific instructions on how to install and configure SSL or TLS, see Using SSL/TLS with Terminal Emulation on the Wavelink Web site.

**NOTE:** Wavelink ConnectPro or TermProxy servers provide SSL/TLS support for connections between the mobile device and the proxy server. They do not support SSL/TLS connections between the proxy server and host.

To configure SSL or TLS, you will need the self-extracting support utility and either the Avalanche, ActiveSync, or AirBeam SSL/TLS package for the Client. The Avalanche packages are device-specific; the ActiveSync and AirBeam packages are not device-specific.

To enable and use SSL/TLS for the TE Client, perform the following steps:

• Installing the SSL/TLS Support Utility on the Host System

• Installing the SSL/TLS Support Package on the Client

• Enabling SSL/TLS

**Installing the SSL/TLS Support Utility on the Host System**

The SSL/TLS support utility is a self-extracting executable that installs the required files that will allow you to configure SSL/TLS and certificates. You can obtain the SSL/TLS support package from the Wavelink Web site.

**Installing the SSL/TLS Support Package on the Client**

The TE Client will not be able to initiate SSL/TLS connections with hosts until you install the SSL/TLS support package on the mobile device.

Use one of the following methods to deploy the SSL/TLS support package to the mobile device:

• **Avalanche Console.** The SSL/TLS support package is available as an Avalanche software package. Add the package to a software profile and deploy it to the desired devices.
• **Microsoft ActiveSync.** The SSL/TLS support package is available as a bundled package that you can deploy over a Microsoft ActiveSync connection between a host system and the mobile device.

• **Third-Party Application.** The SSL/TLS support package is available for some third-party deployment applications.

### Enabling SSL/TLS

SSL/TLS is enabled via the *Host Profiles* dialog box. It is configured per host profile.

When you configure a host profile to use SSL/TLS, the TCP port for the host profile is automatically changed to 992, which is the standard port number for SSL/TLS. If the host system uses a different port, then change the port to the correct setting.

**To configure a host profile to use SSL/TLS:**

1. Access the *Host Profiles* dialog box.
2. From the left panel of the dialog box, select the host profile that you want to configure.
3. Depending on the connection requirements for the host profile, select one of the following:
   - If the host profile specifies a direct connection to a server, then enable the **Use SSL/TLS Encryption** option box in the *Host* tab.
   - If the host profile specifies a connection to a Wavelink ConnectPro or TermProxy server, then enable the **Use SSL/TLS Encryption** option box in the *TermProxy* tab.

**NOTE:** You will not be able to configure the **Use SSL/TLS Encryption** option box in the *TermProxy* tab until you select an option from the *TermProxy Server* menu list.
Enabling SSL for a Host Profile

4 If you want to use server certificates, enable the **Verify server certificates** option and click the **Select Verification Certificates** button.

The **Certificate Manager** dialog box appears.

Click **Insert Certificate** to browse to and import a server certificate.

Click **Create Certificate** to create a certificate and private key that you can then export to a ConnectPro or TermProxy server or other host system.
Chapter 3: Configuring Host Profiles

Managing SSL/TLS Certificates

NOTE: The certificates that you import and/or configure are available for all host profiles that you configure. The imported certificates are added to a list which the Client will check when initiating an SSL/TLS session with a host. If the host does not present a certificate that is in the list, then the Client will not establish a connection with the host.

After you have finished importing/configuring certificates, click OK. The Certificate Manager dialog box closes.

5 After you have finished configuring the host profile, click OK. The new host profile configuration is saved to the host system.

6 Download the new host profile configuration to the mobile device.

NOTE: For information about using Microsoft ActiveSync or Avalanche to download configurations to mobile devices, see Configuring and Deploying the TE Client on page 4.
Host Profiles and Wavelink ConnectPro or TermProxy

The TE Client provides integration with Wavelink ConnectPro (known in earlier versions as TermProxy). ConnectPro provides proxy services to assist in session persistence between the Client and host systems. ConnectPro is free when you are using Terminal Emulation.

**NOTE:** For more information about Wavelink TermProxy or ConnectPro, see the product reference guides.

When you use ConnectPro or TermProxy, use the host profile to configure how the Client will use it. Each host profile has the following options:

- Configuring a ConnectPro- or TermProxy-Only Host Profile
- Configuring ConnectPro/TermProxy Failover

**NOTE:** TermProxy support via the Host Profiles dialog box is only available in version 5.0 (and newer) of Terminal Emulation. While TermProxy 2.x allows connections from any type of TE Client, TermProxy 3.x or ConnectPro requires a 5.0 (or newer) Client.

### Configuring a ConnectPro- or TermProxy-Only Host Profile

If the host profile has a ConnectPro or TermProxy server specified in the TermProxy tab, the Client will try to connect to the proxy server first. When the TE Client cannot connect to the specified proxy server, it will attempt a direct connection to the host. You can configure the Client so that it will only allow connections to the host through a proxy server, however.

**To configure a TermProxy-only connection to a host system:**

1. Access the Host Profiles dialog box.
2. Select the host profile that you want to configure.
3. In the Host tab, enable the Only Use TermProxy Connections checkbox.
Chapter 3: Configuring Host Profiles

Enabling TermProxy-Only Connections

4 Use the TermProxy tab to configure the settings for the ConnectPro or TermProxy server.

**NOTE:** For more information about settings in the TermProxy tab, see TermProxy Tabs on page 20.

5 After you have finished configuring the host profile, click OK.

The new host profile configuration is saved to the host system.

6 Download the new host profile configuration to the mobile device.

Configuring ConnectPro/TermProxy Failover

Use the TermProxy tabs in the Host Profiles dialog box to configure host and ConnectPro or TermProxy failover. You may configure up to three failover connections for a host profile.

When the TE Client attempts to initiate a connection with a host, it will try the addresses listed in the TermProxy tabs first. If it is unable to contact the ConnectPro or TermProxy servers
listed, or if there are no servers listed in the TermProxy tabs, it will try to connect to the host directly. Connection attempts occur in the following order:

- Host specified in the TermProxy 1 tab
- Host specified in the TermProxy 2 tab
- Host specified in the TermProxy 3 tab
- Host specified in the Host tab of the host profile

If the TE Client is unable to contact any of the specified hosts, then it will return an error message.

To configure TermProxy failover servers for a host profile:

1. Access the Host Profiles dialog box.
2. Select the host profile for which you want to configure TermProxy failover.
3. Configure the Host tab.
4. Configure the TermProxy tabs.

**NOTE:** For more information about the settings in the Host and TermProxy tabs, see Host Profile Configuration Options on page 17.

5. After you have finished configuring the host profile, click OK.
   The new host profile configuration is saved to the host system.
6. Download the new host profile configuration to the mobile device.
Chapter 4: Emulation Parameters

Change how the Client interacts with the host using the Configuration Manager utility, which provides an organized list of parameters that you can modify. These may include COM port usage, display, logging, or scanner options.

Use the product configuration utility or the TE Client Avalanche software package to access the Configuration Manager. Use the Configuration Manager to modify the emulation parameters and save it to a new configuration file. When you download the new configuration file to the mobile device, the existing configuration file is overwritten.

Emulation parameters can be applied globally for all host connections, or set on a per-host basis:

- **Global Emulation Parameters.** Global emulation parameters apply to all of the host profiles with which you have configured a Client. When you choose to modify global emulation parameters, you access and use Configuration Manager to modify the Termcfg.bin configuration file. Configuration Manager displays the name of the file that it is modifying in the title bar.

- **Per-host Emulation Parameters.** Per-host emulation parameters apply only to a specific host profile. Any parameters changed on a per-host basis will override global parameters. You can access the emulation parameters for a specific host profile through the Host Profiles dialog box. When you choose to modify per-host emulation parameters, you access and use Configuration Manager to modify the Hostcfg.bin configuration file. Configuration Manager displays the name of the file that it is modifying in the title bar.

**NOTE:** Per-host parameters are a subset of parameters. Not all TE Client emulation parameters are available for modification on a per-host basis.

The left pane of the Configuration Manager displays the emulation parameters that you can modify. The emulation parameters are grouped by category. When you select a parameter in the left pane, information about the parameter displays in the right pane.
Access the Configuration Manager either through Avalanche or ActiveSync, depending on the method you use to install the Client.

- **Using the Configuration Manager with Avalanche**
- **Using the Configuration Manager with Microsoft ActiveSync**

If you want to copy emulation parameters from one device configuration (or Avalanche package) to another, you can export them. For instructions, see Exporting and Importing Settings on page 9.

**Using the Configuration Manager with Avalanche**

If you use Avalanche to install the TE Client on the mobile device, use the Avalanche Console to access the Configuration Manager and modify emulation parameters. You can edit emulation parameters on a global or a per-host basis.

**To edit global emulation parameters from the Avalanche Console:**

1. On the host system, launch the Avalanche Console.
2. In the **Profiles** tab, select the profile that contains the TE Client package.
3. In the Software Packages area, select the TE Client software package and click **Configure**.
   
The **Configure Software Package** dialog box appears.
4. From the list, select **Emulation Parameters** and click **Launch**.
   
The Configuration Manager appears.
5 In the left pane of the Configuration Manager, locate the parameter that you want to modify. Click **Edit > Find** to perform a search. If you enable the **Search all text** option, the search will include the help files as well as the emulation parameters.

**NOTE:** By default, emulation parameters are displayed in a hierarchical tree view. To switch to an alphabetized view, click **View > Tree Mode**.

6 Double-click the emulation parameter.

A dialog box appears that allows you to modify the parameter configuration.

![Modifying an Emulation Parameter](image)

7 Configure the parameter and click **OK**.

8 Click **Save**.

9 Close the Configuration Manager.

10 Download the new configuration to the mobile device.

To edit per-host emulation parameters from the Avalanche Console:

1 On the host system, launch the Avalanche Console.

2 In the **Profiles** tab, select the profile that contains the TE Client package.

3 In the Software Packages area, select the TE Client software package and click **Configure**.

The **Configure Software Package** dialog box appears.

4 From the list, select **Host Profiles** and click **Launch**.

The **Host Profiles** dialog box appears.

5 From the list of host profiles, select the host profile that you want to configure.

6 Select the **Configuration** tab and click **Modify**.

The Configuration Manager appears.

7 In the left pane of the Configuration Manager, locate the parameter that you want to modify. Click **Edit > Find** to perform a search. If you enable the **Search all text** option, the search will include the help files as well as the emulation parameters.
NOTE: By default, emulation parameters are displayed in a hierarchical tree view. To switch to an alphabetized view, click View > Tree Mode.

8 Double-click the emulation parameter.

A dialog box appears that allows you to modify the parameter configuration.

9 Configure the parameter and click OK.

10 Click Save.

11 Close the Configuration Manager.

12 Download the new configuration to the mobile device.

Using the Configuration Manager with Microsoft ActiveSync

If you use the product installation and configuration utility to install the TE Client to the mobile device via a Microsoft ActiveSync connection, use the same product installation and configuration utility to access the Configuration Manager and modify global emulation parameters. You can edit emulation parameters on a global or a per-host basis.

To edit global emulation parameters from the Microsoft ActiveSync utility:

1 On the host system, launch the TE Microsoft ActiveSync utility.

The Wavelink Product Configuration dialog box appears.

2 Click the Emulation Parameters button.

The Configuration Manager appears.

3 In the left pane of the Configuration Manager, locate the parameter that you want to modify. Click Edit > Find to perform a search. If you enable the Search all text option, the search will include the help files as well as the emulation parameters.

NOTE: By default, emulation parameters are displayed in a hierarchical tree view. To switch to an alphabetized view, click View > Tree Mode.

4 Double-click the emulation parameter.

A dialog box appears that allows you to modify the parameter configuration.
Chapter 4: Emulation Parameters

Modifying an Emulation Parameter

5  Configure the parameter and click OK.
6  Click Save.
7  Close the Configuration Manager.
8  Download the new configuration to the mobile device.

To access per-host emulation parameters from the Microsoft ActiveSync utility:
1  On the host system, launch the TE Microsoft ActiveSync installation utility.
   The Wavelink Product Configuration dialog box appears.
2  Click the Host Profiles button.
   The Host Profiles dialog box appears.
3  From the list of host profiles, select the host profile that you want to configure.
4  Select the Configuration tab.
Chapter 4: Emulation Parameters

42

Selecting to Configure Per-Host Emulation Parameters

5  Click Modify.

The Configuration Manager appears.

6  In the left pane of the Configuration Manager, locate the parameter that you want to modify. Click Edit > Find to perform a search. If you enable the Search all text option, the search will include the help files as well as the emulation parameters.

NOTE: By default, emulation parameters are displayed in a hierarchical tree view. To switch to an alphabetized view, click View > Tree Mode.

7  Double-click the emulation parameter.

A dialog box appears that allows you to modify the parameter configuration.

8  Configure the parameter and click OK.

9  Click Save.

10 Close the Configuration Manager.

11 Download the new configuration to the mobile device.
Chapter 5: Scripting

The Script Editor provides the ability to create and execute scripts that automate processes on the TE Client. The Script Editor is included in TE Client 5.1 and later versions. This section includes the following information:

- Overview of Scripting
- Launching the Script Editor
- Creating Scripts Using the Script Editor
- Performing Script Capturing
- Editing Scripts
- Importing Scripts
- Saving and Exporting Scripts
- Deploying Scripts
- Executing Scripts

Overview of Scripting

The following steps outline the process of creating scripts using the Script Editor:

1. **Launch the Script Editor.** You can launch the script editor from the Avalanche Console or the ActiveSync configuration utility.

2. **Create a script using the Script Editor.** You can use the Script Editor to manually create the script code.

   - Or-

   **Create a script using the Script Capture option.** You can turn on Screen Capture and perform the actions you want included in your script.

3. **Configure an execution method for your script.** You need to select from the available options the way you want to execute your script.

4. **Deploy the script to the Velocity Client.** Use Avalanche or ActiveSync to deploy the script to the Client.

5. **During an emulation session, execute your script from the Velocity Client.** Using the activation method you selected for the script, you can activate and execute your script.
Scripts can only be run while a session is connected to a host. When a connection is dropped, the script is terminated. If you switch between sessions, the script running in the first session will be suspended until that session is active again. Scripts should be designed to perform their function and then immediately exit.

**NOTE:** The actions and settings you use to create Terminal Emulation scripts are located in a separate document called *Wavelink Terminal Emulation Scripting Reference Guide*. The document explains the usage of each action in detail and provides examples. The *Scripting Reference Guide* is located on the Wavelink web site.

## Launching the Script Editor

If you are using Avalanche Console to deploy the TE Client, you can launch the Script Editor from the Avalanche Console. Scripts created by or imported into the Avalanche Script Editor will automatically be deployed to the remote devices. If you use ActiveSync to install, access the Script Editor from the ActiveSync configuration utility.

**To launch the Script Editor from the Avalanche Java Console:**

1. From the Avalanche Console, navigate to the **Profiles** tab, and select the profile that contains the TE Client package.

2. In the Software Packages area, select the TE Client software package and click **Configure**.

   The **Configure Software Package** dialog box appears.

3. Select **Script Editor** and click **Launch**.

   The Script Editor opens.

4. Click **Add** to add a new script.
From this dialog box, you can create and configure scripts.

To launch the Script Editor from the ActiveSync configuration utility:

1 On the host system, launch the TE Microsoft ActiveSync utility.
   The Wavelink Product Configuration dialog box appears.

2 Click the Emulation Parameters button.
   The Script Editor opens.

3 Click Add.

4 From this dialog box, you can create and configure scripts.

Creating Scripts Using the Script Editor

Once you have named your script and selected an activation method, you can use the Actions tab in the Script Editor to build the script.

For detailed information and examples about building the script code see the Terminal Emulation Scripting Reference Guide.
This section provides specific tasks for creating scripts using the Script Editor:

- Selecting the Activation Method
- Creating Variables
- Selecting Host Profiles

**Selecting the Activation Method**

When you create a script, you assign it a unique name and an activation method. A script with no activation method selected can still be called by another script, but it cannot be activated by itself. You can select from the following activation methods in the Script Editor:

- **Select from Menu** Activates the script from a script execution option added in the TE Client menu.
- **Called from Another Script** Activates the script only when it is called by another script.
- **On Key Combination** Activates the script when the key combination is pressed. For information on using the Diagnostics Utility to obtain key values, see Using the TE Client Diagnostics Utility on page 114.
- **When Session Connects** Activates the script when a session begins for the host profile the script supports. You should not have more than one script set to start when a session begins because the first script started will prevent any other scripts from running while it waits for the initial screen.
- **On Barcode, MSR, or RFID Scan** Activates the script when an item is scanned. This option is only available after you have created the string variable _Scan_String to obtain the initial scan data and the number variable _Scan_Type to obtain the type of scan data.

See the Terminal Emulation Scripting Reference Guide for the values of different symbologies.

**NOTE:** If you want to perform special processing on items scanned into the computer, the Scan Handler is often powerful enough to make the changes you need. The Scan Handler settings, found in the Configuration Manager, are located in **Emulation Parameters > Scanner > Common > Scan Handler**.
On Screen Update Activities the script every time the text on the emulation screen changes. This includes updates from the host or when the user presses a key and the key value is shown on the screen. It is recommended that you limit the host profiles that a script using this method will support.

To select the activation method for a script, launch the Script Editor configuration dialog box and choose the appropriate method on the General tab.

In addition to the activation methods available in the Script Editor, you can also activate a script from the screen reformatter or, if you are using the Industrial Browser, from a web page. If you choose one of these methods, you don't need to specify the activation method in the Script Editor. For more information on using these options, see XXX.

Creating Variables

There are three types of values recognized by Terminal Emulation scripting: Booleans (TRUE or FALSE values), numbers (integers), and strings. Every action that returns a value returns one of these types. Variables provide a way to save the result of an action for use later as an argument for another command.

Variables can be created and edited under the appropriate Variable tab while editing the script. It is also possible to create new variables while editing an action.

When a script first starts, all the variables will have known values: Boolean variables will be FALSE, number variables will be 0, and string variables will be empty. One possible exception to this is when a script activates another script.

When a variable is persistent, the value remains after the script exits. Persistent variables are not script- or session-specific; once a value is assigned, any script in any emulation session can use a persistent variable to access that value.

Two scripts are referencing the same persistent variable if both scripts contain a persistent variable of the same type and same name.

Writing new values to persistent variables will slow your application, so they should be used only when necessary. If you want to use a persistent variable that will change values frequently, write your script with a regular variable that only changes the value of the persistent variable before the script pauses or exits.

To create a variable:

1. Determine which type of variable you want to create: Boolean, number or string.

2. From the Script Editor, select the tab that corresponds with the type of variable you want to create.

3. Click Add.
4 In the *Edit Variable* dialog box, enter the name of the new variable.

![Adding a New Variable](image)

5 Enable the **Make this variable persistent** checkbox if you would like the variable to persist after the script exits. This allows it to be used by other scripts or sessions.

6 Click **OK**.

   The new variable appears in the corresponding tab.

**Selecting Host Profiles**

For each script, you can specify which host profiles will be supported by that script. You may select host profiles from the **Host Profiles** tab.

If the script is generated by script capturing, it is a good idea to limit that script to a host profile that was in use when the script was captured. The default — no host profile — allows the script to be run when any host profile is used.

**To select host profiles:**

1 From the Script Editor, select the **Host Profiles** tab.

2 Click **Add**.

   The **Select Host** dialog box opens.

3 Select which host you want to use from the list of hosts. You must create host profiles before you can specify them in the script.

4 Click **OK**.

   The host appears in the **Host Profiles** tab.

**Performing Script Capturing**

Script capturing is an easy way to generate a script that will automate doing something you can do manually. While script capturing is turned on, it will capture the key presses and
mouse/cursor movements so they can be replayed when the script is activated. A script is recorded from the device where the Client is running.

To perform a script capture:

1. Launch the Client and navigate to the emulation screen you want the script to start at.

2. From the Term or Options menu, select Scripting > Start Capture.

3. At the prompt, select Yes to verify the current screen text.
Selecting **Yes** makes the captured script start with an `If_not` command that tells the script to exit if the current screen does not match. Unless you know that your script will only run from the correct screen (for example, a script that is run only when a session first starts, or a script called by another script), you should select **Yes**. Select **No** if you do not want to verify the current screen text.

If you select **No**, click the **Verify Screen Contents** and **Save Cursor Position** buttons when you start your script capture. This will cause your script to wait for the Client to finish updating the screen before processing script actions.

4 Perform any actions you want to include in the script. Special action buttons related to recording the script appear on the screen.

![Verify Screen Contents and Save Cursor Position Buttons](image)

**Verify Screen Contents** (or **Screen**l) will cause the generated script to pause and wait for the screen to be updated. The pauses are necessary because the scripts can run much faster than the interaction with the host. **Save Cursor Position** (or **Cursor**) will ensure that the cursor is moved to the correct position before the script continues. **Field Data ID** (or **ID**) allows you to assign symbologies and/or Data IDs to a field so that scan data with matching criteria is sent to that field. **Stop Capture** (or **Stop**) ends the script capture.

**NOTE:** The Field Data ID feature, specific to IBM 5250 emulation, allows you to use scripting to configure Field Data Identifiers. Field Data Identifiers assign a unique ID (such as a letter) to each field on the screen. Any time a barcode beginning with that ID is scanned, the barcode information automatically populates the corresponding field. For more information and examples related to the Field Data ID feature, see the *Terminal Emulation Scripting Reference Guide*.

5 Each time the screen changes, click the **Verify Screen Contents** button.

6 When you are finished capturing the actions you want in the script, click **Stop Capture**. Once you have captured a script, the Script Editor opens. This allows you to name the script and select an activation method. You could also use the **Actions** tab to add actions for any error condition that the user may encounter.
Editing Scripts

You can edit scripts that are created manually and scripts that are generated from the script capture option.

To edit scripts:
1. Launch the Script Editor.
2. Select the script you want to edit from the Script Editor script list.
3. Click Edit.
4. Make the desired changes in the Script Editor configuration dialog box.
5. Click OK to save your changes.

Once you have completed editing the script you have two options:

- Export the script to a specified location using the Export button in the Script Editor. For more information, see Saving and Exporting Scripts on page 52.
- Deploy the script to the Client and execute it by launching the TE Client and performing the activation method you assigned to this script. For more information, see Executing Scripts on page 53.

Importing Scripts

You can use the Import button in the Script Editor to import previously created scripts. You can only import scripts that have been created using the Script Editor. When a script is exported, it is saved with a .wls extension.

To import a script:
1. From the Script Editor, click the Import button.
   
   The Select the Script File dialog box opens.
2. Navigate to and select the script file.
3. Click Open.

   The file is imported into the Script Editor and the name appears in the list.

   Once you have imported the file, you can edit the script. For more information, see Editing Scripts on page 51.
Saving and Exporting Scripts

After you finish building a script, your script is automatically saved in the Script Editor. You can also export a script and save it in a specific location on the network.

Scripts are saved as .wls files. Scripts cannot be viewed outside the Script Editor and must be imported back in to the Script Editor to view or edit.

**NOTE:** If you want to copy a group of scripts, or copy scripts along with screen reformatter settings, you can export it using either Avalanche or the ActiveSync installer. For instructions, see Exporting and Importing Settings on page 9.

To export a script:
1. From the Script Editor script list, select which script you want to export.
2. Click the **Export** button.
   
   The *Create the Script File* dialog box opens.

3. Navigate to the location to which you want to export your script.
4 Click Save.

To view an exported script you will need to import that script into the Script Editor. For more information, see Importing Scripts on page 51.

Deploying Scripts

Scripts are deployed to the TE Client the next time the Client syncs using Avalanche or ActiveSync. For information on deploying configurations to the Client, see Configuring and Deploying the TE Client on page 4.

Executing Scripts

When you create a script, you configure an activation method for that script. This section provides information about activating scripts using each of the following activation methods:

- **Select from Menu**
- **From Another Script**
- **On Key Combination**
- **When Session Connects**
- **On Barcode, MSR, or RFID Scan**
- **On Screen Update**
- **From the Screen Reformatter**
- **From Web Pages**

For information on assigning an activation method to a script, see Selecting the Activation Method on page 46.

**Select from Menu**

This option allows you to activate a script from the Options menu. You cannot start a script while a script is running for the current session or if the session is not connected.

To activate a script from the TE Client menu:

1 Launch the TE Client.

2 From the Options menu, select Scripting > Execute Script.
3 If more than one script is available for the current host profile, select which script you want to use from the list.

**From Another Script**

To use a script to call another script, use the following format:

```
Call ("Name of the script", argument1, argument2, argument3, argument4)
```

The arguments are optional and you cannot use more than four of them. They can be variables, strings, Booleans, or numbers. If the argument is a string, it must have quotation marks around it.

**On Key Combination**

This option lets you launch a script whenever a specified key combination is pressed, if it is currently possible for a script to run. You cannot start a script while a script is running for the current session or if the session is not connected.

**To execute a script on key combination:**

- During a session, press the key combination you assigned for executing the script.

**When Session Connects**

This option causes the script to activate when the host profile it supports is activated. If you use this option, Wavelink strongly recommends that you limit the script to the appropriate host profiles. The script should wait for the appropriate screen to appear before it activates in order to prevent errors. The first script that starts will prevent any other scripts from running...
while it waits for the initial screen, so you should not have more than one script set to start when a session connects.

To execute when the session connects:
1. Launch the TE Client.
2. From the Term or Options menu, select Connect.
3. Select the host to which you want to connect.
4. Click OK.

The script will run upon connection.

**On Barcode, MSR, or RFID Scan**

This option runs a script each time the scanner is used. To execute a script using this method, launch the TE Client and then use the scanner.

The following sample script inserts a string (which could be just one character long) after the first six characters of any barcode at least six characters long.

A few notes about this sample script:

- `ScanData` is a string variable with the original barcode.
- `NewString` is a variable where you store the new barcode.
- `ScanType` is the number variable that keeps the type of scan data received.
- `OldLength` is an integer variable.
- `XXYY` is the string you insert.

```plaintext
OldLength=String_Length(ScanData)
If (Number_Greater_Than_or_Equal(OldLength,6))
    NewString=String_Combine(String_Left(ScanData,6), "XXYY")
    NewString = String_Combine(NewString,String_Right(ScanData, Number_Minus(OldLength,6)))
Else
    NewString = ScanData
End_If
Scan_String(NewString,ScanType)
Return
```

This second example converts any DataMatrix scan values to PDF417 scan values. The `ScanData` and `ScanType` variables described for the previous example are used again.

```plaintext
If (Number_Equal(ScanType,Get_Scan_Type_Value("DATAMATRIX")))
    Scan_String(ScanData,Get_Scan_Type_Value("PDF417"))
Else
```
Scan_String(ScanData,ScanType)
End_If
Return

**On Screen Update**

This option causes the script to be activated (if activation is allowed) every time the text on the emulation screen changes. This includes updates from the host or when the user presses a key and the key value is shown on the screen.

The following example generates a script that enters a command each time a particular string appears on the screen:

```
Label:Start:
If (String_Equal(Get_Screen_Text_Columns(1,1,5),"Ready", 0,FALSE))
Keypress_String("Proceed")
Keypress_Key("Enter")
End_If
Wait_For_Screen_Update
Goto: Start
Return
```

If this script is set to activate when the session first connects, it will work as desired with one limitation. Because it is always activated, no other scripts can be activated during the emulation session.

Here is an alternate implementation:

```
If (String_Equal(Get_Screen_Text_Columns(1,1,5), "Ready", 0, FALSE))
Keypress_String("Proceed")
Keypress_Key("Enter")
End_If
Return
```

If the script is set to run each time the screen updates, you get the desired behavior. Because the script is not active all the time, other scripts can be activated as well.

**NOTE:** Use this activation option carefully as it can cause a script to be executed frequently.

**From the Screen Reformatter**

A Wavelink script can be launched for a specific screen using the screen reformatter. When a script is added for a screen in the reformatter, it is considered a screen action. When the correct screen appears on the device, screen actions (including speech-to-text and text-to-speech actions) are performed in the order they appear in the Descriptive View. For information on adding a script to a screen using the screen reformatter, see Adding Scripting Support on page 94.
From Web Pages

Activate the script for the Industrial Browser from a web page using the `wls` type, followed by the script name. If you plan to launch a script from a web page, do not select a script activation method when you create the script.

Executing Scripts from Web Pages Example 1

This example launches a script called `WebAuto` when the web page first loads.

```html
<title>TE70 Test1 - Launch Telnet Scripts</title>
<meta http-equiv="OnStartup" content="wls:WebAuto">
```

Executing Scripts from Web Pages Example 2

This example launches a script called `WebClick` when a user clicks the hyperlink “here” on the web page.

```html
<p>Click `<a href="wls:WebClick">here</a>` to launch the "WebClick" script.</p>
```
Chapter 6: Keyboard Creator

The keyboard creator allows you to modify or create custom virtual keyboards to use during an emulation session. Keyboard files contain all the keyboards needed for a given emulation (5250, 3270, VT100, VT220, HP, or WEB). Use the following table to determine the name of the keyboard file that should be edited for a particular emulation type.

<table>
<thead>
<tr>
<th>File Name</th>
<th>Emulation Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>EM5250.KB</td>
<td>5250</td>
</tr>
<tr>
<td>EM3270.KB</td>
<td>3270</td>
</tr>
<tr>
<td>EMVT.KB</td>
<td>VT100, VT220</td>
</tr>
<tr>
<td>EMHP.KB</td>
<td>HP</td>
</tr>
<tr>
<td>EMWEB.KB</td>
<td>WEB</td>
</tr>
<tr>
<td>EMNONE.KB</td>
<td>Displayed when a session is not connected</td>
</tr>
<tr>
<td>EMNUM.KB</td>
<td>Displayed for numeric keyboard</td>
</tr>
</tbody>
</table>

The .KB files are used by the keyboard creator. When you save your keyboard modifications, a matching file with the .KBB extension is also saved. This file is a binary representation of the keyboard file and will be used by the Client to display the keyboards.

Additionally, import your own graphics files (bitmaps) to create unique buttons for the keyboard.

This section provides the following information:

- Launching the Keyboard Creator
- Creating Keyboards
- Creating and Configuring Keys
- Importing Keyboard Graphics
- Deploying the Keyboard to the TE Client

Launching the Keyboard Creator

The Keyboard Creator is installed as part of the TE Client. It allows you to edit or create custom keyboards for the Client.
NOTE: If you want to copy keyboards from one device configuration (or Avalanche package) to another, you can export them. For instructions, see Exporting and Importing Settings on page 9.

To launch from Avalanche:
1. From the Avalanche Console, navigate to the Profiles tab, and select the profile that contains the TE Client package.
2. In the Software Packages region, select the TE Client software package and click Configure.
   
The Configure Software Package dialog box appears.
3. Select Keyboard Creator and click OK.
   
The Keyboard Creator opens.

To launch from the ActiveSync configuration utility:
1. On the host system, launch the ActiveSync utility.
   
The Wavelink Product Configuration dialog box appears.
2. Click the Keyboard Creator button.
   
The Keyboard Creator appears.

Creating Keyboards

There are two default keyboards: the default alpha keyboard and the default numeric keyboard. The default alpha keyboard is displayed by default. The default numeric keyboard is displayed when in a numeric field (5250 and 3270 only).

This section provides the following keyboard information:

- Adding a Keyboard
- Sizing Keyboards
- Deleting Keyboards

Adding a Keyboard

Multiple keyboards can be included in each keyboard file. The keyboards are linked together by shift keys (special keys which display another keyboard).

To add a keyboard:
1. Launch the Keyboard Creator.
2. Select Keyboard > New Keyboard from the menu.
3 Enter a new name for the keyboard.

![Keyboard](image)

Creating a New Keyboard

**NOTE:** Keyboard names must start with a letter, may only contain numbers or letters, and can only be 11 characters long.

4 Use the Key configuration options to configure each key of the keyboard.

For more information, see Creating and Configuring Keys on page 61.

**Sizing Keyboards**

You can use the mouse to resize a keyboard. As you increase the size of the keyboard, the size of the application area will decrease.

**To resize the keyboard:**
1 Mouse over the top border, right-side border, or the upper-right corner of the keyboard.
2 When the double-sided arrows appear, click and drag the keyboard to the desired size.

**Deleting Keyboards**

When deleting a keyboard that has keys associated with it, an option will be presented for dealing with any connections to the keyboard. Keys that reference the keyboard can be deleted, set to an empty value or redirected to another keyboard.

**To delete a keyboard:**
1 Select **Keyboard > Delete Keyboard** from the menu.
2 Select what action to take for referenced keys.
Creating and Configuring Keys

There are three types of keys that can be on a keyboard:

- **Normal keys** represent letters, numbers, or other characters in the emulation and can also represent special emulation specific function keys.
- **Shift keys** can point to any other keyboard in the current keyboard file.
- **Hide keys** hide the keyboard and allow an unobstructed view of the emulation screen.

This section provides the following information:

- **Adding a New Key**
- **Sizing and Positioning Keys and Rows**
- **Deleting Keys**

**Adding a New Key**

You can add new keys to a keyboard and configure the key values and configure the following options:

- **Label.** Enter the text that will appear on the virtual key when it is displayed.
- **Reverse.** Enable this option for a key that indicates the active keyboard type.
- **Key Value.** Select from Key, Normal, Keyboard (shift), or Hide. Key values allow you to select emulation-specific actions to be assigned to the keys. The list of keys available will vary depending on the emulation type selected.
NOTE: Normal key values can be displayed or entered as a character value (the actual character created by the keystroke is shown), a decimal value (for characters which cannot be shown), or a hexadecimal value (for scan codes of special function keys).

To add a new key:

1. Select **Keyboard > Add Key**.

   The new key will appear in the top left corner of the keyboard, or directly to the right of a selected key (if it will fit).

2. Modify the values for the key using the key configuration options.
3 Repeat to create additional keys for the keyboard.

**Sizing and Positioning Keys and Rows**

You can use the configuration options in the Key region of the Keyboard Creator to modify the size and position of the keys on the keyboard.

The **Fine Adjustments** drop-down menu allows you to select what object you want to modify:

- **Key Position.** Select this option to move a selected key on the keyboard. You can also adjust the key position by clicking on the key and dragging it to the desired position.

- **Row Position.** Select this option to move an entire row.

- **Keyboard Position.** Select this option to move all the keys on the keyboard.

- **Key Size.** Select this option to adjust the size of the key.

Once you select the object you want to modify, you can use the arrow buttons to move or size the keys and rows. The **Adjust Distance** slider determines how much of an effect each click of an arrow button will have. This is set on a scale of 1-10 pixels.

**To position a key:**

1 Select an existing key or click **New Key**.

2 From the **Fine Adjustments** drop-down menu, select **Key Position**.

3 Use one of the following methods to move the key:
   - Use the arrow buttons to position the key in the desired location.
   - Drag and drop the key to the desired location.
To position a row:
1. Click a key in the row you want to position.
2. From the **Fine Adjustments** drop-down menu, select **Row Position**.
3. Use the arrow buttons to position the row in the desired location.

To resize a key:
1. Select an existing key or click **New Key**.
2. From the **Fine Adjustments** drop-down menu, select **Key Size**.
3. Use the arrows to adjust the size.

Deleting Keys

You can delete keys that you do not want from the keyboard.

To delete a key:
1. Select the key you want to delete.
2. Select **Keyboard > Remove Key**.

Importing Keyboard Graphics

The default keyboard draws the keys on the computer screen. However, you can import a graphic to be displayed instead of the created keys. An imported graphic will be embedded in the `.KB` and `.KBB` files, so you will not need to save the imported graphic file on the device separately.

When you import a graphic to use as a key or set of keys, you will still need to create and position key values. Use the slider bar to change how dark the graphic and keys are while editing so that you can size and position the keys correctly.

**NOTE:** Be sure to label the buttons you create. If the mobile device is unable to display the bitmap image, the labels will still appear.

To import a graphic:
1. In the Keyboard Creator, click **Import**.
2. Navigate to the location of the bitmap image you want to import.
3. Click **Open**.
4. Click the **Size Keyboard to Graphic** button to make the keyboard the same size as the imported graphic.
5 Use the slider bar to adjust the how dark and how light the graphics and buttons appear when editing.

Deploying the Keyboard to the TE Client

Once you have completed creating your keyboard and keys, click the Save icon to save your keyboard, and then exit the Keyboard Creator. Your TE Client will update with the new keyboard the next time the mobile device syncs.
Chapter 7: Resource Editor

The Resource Editor allows you to import sound and picture (.wav and .bmp format) files that can be deployed to your mobile devices. Launch the Resource Editor, add the bitmap and sound files, then update the device.

- Adding a Bitmap
- Adding a Sound
- Editing Files

**NOTE:** If you want to copy resource files from one device configuration (or Avalanche package) to another, you can export them. For instructions, see Exporting and Importing Settings on page 9.

To launch from the ActiveSync configuration utility:

1. On the host system, launch the ActiveSync utility.

   The Wavelink Product Configuration dialog box appears.

2. Click the **Resource Editor** button.

   The Resource Editor appears.

To launch from Avalanche:

1. From the Avalanche Console, navigate to the Profiles tab, and select the profile that contains the TE Client package.

2. In the Software Packages region, select the TE Client software package and click **Configure**.

   The Configure Software Package dialog box appears.

3. From the menu list, select **Resource Editor** and click **OK**.

   The Resource Editor opens.
Chapter 7: Resource Editor

Adding a Bitmap

Any graphic file with a .bmp extension can be added to the Resource Editor.

To add a bitmap:

1. From the right pane of the Resource Editor, click Add new bitmap.

   The Open dialog box appears.

2. Navigate to the desired file and click Open.

   The file appears beneath the Bitmaps folder in the left pane of the Resource Editor.

Adding a Sound

Any sound file with a .wav extension can be added to the Resource Editor.

To add a sound:

1. From the right pane of the Resource Editor, click Add new sound.

   The Open dialog box appears.

2. Navigate to the desired file and click Open.
The file appears beneath the **Sounds** folder in the left pane of the Resource Editor. Play the sound by selecting it and clicking **Play** in the right pane of the editor.

**Editing Files**

You can use the Resource Editor to rename or remove files.

**To rename files:**

1. In the left pane of the Resource Editor, expand the appropriate folder and select the desired file.
2. In the right pane of the Resource Editor, click **Rename**.
   
   The *Rename Resource* dialog box appears.
3. Enter the new file name in the available text box.
4. Click **OK**.

   The new file name appears in the left pane of the Resource Editor.

**To remove files:**

1. In the left pane of the Resource Editor, expand the appropriate folder and select the desired file.
2. In the right pane of the Resource Editor, click **Remove**.
   
   The *Resource Editor* dialog box appears.
3. Click **Yes**.

   The file is removed from the Resource Editor.
Chapter 8: Reformatting Emulation Screens

The TE Client screen reformatter allows you to modify the appearance of emulation screens. You can create a screen layout that includes items you want the mobile device user to see, and excludes items that should not be visible to the user. The screen reformatter also allows you to add scripting and Speakeasy actions to a screen.

The screen reformatter does not change the actual emulation screen, only the appearance of the screen as it displays on the device. Therefore, any scripts specific to an emulation screen will still work correctly. In addition, any other items specific to an emulation screen will continue to function properly even if they are not visible on the modified screen.

**NOTE:** The screen reformatter is included in TE Client 7.1 and later versions.

The following steps outline the process of modifying emulation screens using the screen reformatter:

1. **Perform a screen capture.** Use the screen capture function within the TE Client or Session Monitor to capture any emulation screens you want to reformat.

2. **Import the screen capture into the Screen Reformatter.** Import the captured screens you want to reformat.

3. **Reformat the emulation screen.** Copy the regions of the emulation screen which you would like to include on the modified screen. You can also modify the screen further by changing the background color and adding things like text, scripts, and Speakeasy functions.

4. **Assign verification items.** You can select a host profile and/or items on the emulation screen which will be verified to determine whether the reformatted screen should be displayed.

5. **Save the reformatted screens as part of the Client configuration.** After you have modified the screens as desired, click the Save icon to save your changes.

6. **Deploy to the TE Client.** The reformatted screens are deployed to the TE Client the next time it syncs.

The screen reformatter modifies the screens for a specific Client. You can export modified screens in order to use them with other Clients, however.

This section contains the following information:

- Performing a Screen Capture
- Using the Screen Reformatter
- Importing Screens
Chapter 8: Reformatting Emulation Screens

- Organizing Screens
- Modifying a Screen
- Verifying a Screen
- Speakeasy and Scripting Support
- Deploying Reformatted Screens
- Exporting Screens

**NOTE:** The Screen Reformatter does not work with Web emulation.

### Performing a Screen Capture

In order to reformat the screens for an emulation session, you need to perform a screen capture. You can do this from the TE Client or from a Session Monitor. Screen captures are saved with the extension `.wltsc` in the location of your choice.

Screen capture files can be combined and reordered during the editing process.

**To capture:**

1. From the Windows TE Client, click **Term > Screen Capture**.
   - Or-
   2. From Session Monitor, select **File > Screen Capture**.

**NOTE:** For more information about using Session Monitor, see [Session Monitor](#) on page 123.

The `Screen Capture File` dialog box appears.

2. Specify the location where you want to save the screen capture and click **Save**.
   
   The `Screen Capture File` dialog box closes and a check mark appears next to the **Screen Capture** menu item, indicating that screen capturing is enabled.

3. Connect to the desired host profile and access the screens that you want to reformat.

4. When you have finished capturing the desired screens, select **Screen Capture** from the **Option** or **Term** menu.

   The screen capture is saved and the check mark next to the **Screen Capture** menu item disappears, indicating that screen capturing is disabled.

**NOTE:** Screen capturing is also disabled when you close the TE Client.
Using the Screen Reformatter

From the screen reformatter, you can import screens, organize and modify them, and save them as master files to be deployed to the client. The screen reformatter should be accessed from the Client package you want the screens to be associated with.

The Screen Reformatter is composed of several different sections or views that can be resized to fit your contents. The Screen Reformatter also has a status bar and a tool bar.

The Screen Reformatter elements are described in the following sections:

- Tree View
- Initial Screen View
- Modified Screen View
- Descriptive View
- Status Bar
- Tool Bar

**To access the screen reformatter from the Windows TE Client:**

1. Open the TE Client.
2. From the **Term** menu, select **Configure > Screen Reformatter**.
   
   The **Input Password** dialog box appears.
3. Enter the password in the **Input Host Config Password** text box and click **OK**.

   The Screen Reformatter opens.

**To access the screen reformatter from Avalanche:**

1. From Avalanche, select the software profile associated with the TE package.
2. Select the package from the Software Packages list and click **Configure**.

   The **Configure Software Package** dialog box appears.
3. Select **Screen Reformatter** and click **Launch**.

   The Screen Reformatter opens.

**To access the screen reformatter from the ActiveSync configuration utility:**

1. Open the TE Client configuration utility.
2. Click the **Screen Reformatter** button.
Chapter 8: Reformatting Emulation Screens

The Screen Reformatter opens.

**Tree View**

The Tree View is the left section of the screen reformatter. It displays all of the screens imported. You can use the tree view to navigate to a specific screen; select, delete, duplicate, or rename screens; create collections to organize the screens; and drag-and-drop screens to reorder them or put them in a collection.

To change the appearance of the Tree View, you can right-click in the Tree View or use the options in the View menu. You can hide the Tree View, display or hide the expansion buttons for collections, or display small or large thumbnails of the screens.

**Initial Screen View**

The Initial Screen View is the bottom section of the Screen Reformatter. This view displays the screen that was captured, before modifications. You can toggle a grid display over the screen view by clicking **View > Show Grid**.

**Modified Screen View**

The Modified Screen View is the top left section of the Screen Reformatter. This view displays the modified version of the captured screen. The Modified Screen View consists of the areas copied from the original screen capture, as well as any added text.
You have successfully logged in!

Press $ to shutdown
Press Q to quit
Press X to exit
Press H for hyperspeed

*Modified Screen View*

The solid white line outlines the screen area, and the dotted lines surround areas of added or copied text. Resize the screen area or the Modified Screen View by clicking the border and dragging it. You can also specify the number of rows and columns by right-clicking the view and selecting **Screen Size**. Toggle a grid display over the screen view by clicking **View > Show Grid**.

**Descriptive View**

The Descriptive View is the top right section of the Screen Reformatter. This view displays information about the Modified Screen.
Chapter 8: Reformatting Emulation Screens

Login

Screen Verify Criteria
Row 8, Column 1: Text is "login: " (Length 7)

Modified Screen Creation
Screen Size: 15 Rows, 20 Columns
Font Size: Same as initial screen
Background Color: Bright Blue
Row 5, Column 1: Copy Area at Row 8, Column 1, Height 1, Width 20

Supporting Actions
No Supporting Actions Specified

Screen Comments
Login screen for Project: Coriolis

Screen Details
Screen Name: Login
Screen Collection: Coriolis

Descriptive View

The Descriptive View information is divided into the following sections:

- **Screen Verify Criteria.** This section contains a list of items that are used to determine whether the modified emulation screen should be displayed. In order for the modified screen to be displayed, all of the text and field verification items must match. If there are multiple cursor or host profile verification items, only one of each must match.

- **Modified Screen Creation.** Modified Screen Creation contains a list of actions that will be used to reformat the screen. These include added text and copied text.

- **Supporting Actions.** Supporting actions are scripting or Speakeasy actions performed by the Screen Reformatter when a modified screen is used.

- **Screen Comments.** Any comments on how the screen is modified or the purpose of the screen will appear in this section.

- **Screen Details.** This section contains information about the original screen capture.

Status Bar

The status bar is located at the bottom of the Screen Reformatter window. You can choose to display or hide the status bar by enabling or disabling the **Status Bar** option in the **View** menu.
The left side of the status bar displays information about menu options and tool bar buttons when the mouse pointer is hovering over them. The right side of the status bar indicates when the Caps Lock, Num Lock, and Scroll Lock are engaged.

**Tool Bar**

The tool bar provides buttons for common actions in the screen reformatter. You can display or hide the tool bar by enabling or disabling the Tool Bar option in the View menu. The following table provides information about each Tool Bar button.

- ![Open button](image)
  - Click this button to access the Open dialog box and import a screen capture or master file.

- ![Save button](image)
  - Click this button to save screen reformating changes as part of the Client configuration. If you want to save the screens in order to use them with a different Client, use File > Export Master File.

- ![Undo button](image)
  - Click this button to undo the last change.

- ![Redo button](image)
  - Click this button to redo the last change.

- ![Help button](image)
  - Click this button to display the help index.

- ![Search button](image)
  - Click this button to search for a specific item within the help.

**Importing Screens**

When you perform a screen capture, the screens are saved as a .wltsc file. These files can be imported into the screen reformatter in order to modify the screens. After you modify screens, you can save them as a master file with a .wlrmf extension if you want to export them for a different device or TE Client.

You can merge screen capture files and master files to make it easier to manage modified screens. Import the first file, and then import additional files to merge them with the currently open screens.

**NOTE:** When there are duplicate screens in the screen capture when you import it, each screen will only be imported once. Any duplicates will be discarded.
During a merge, the reformatter will only import new screens. If there are screens in the file you are adding that match screens already open, the reformatter will discard them.

**To import screens:**

1. From the **File** menu, select **Import Screen Capture** or **Import Master File**.
   
The **Import Screen Capture** dialog box appears.

2. Navigate to and select the desired screen capture or master file.

3. Click **Open**.
   
   If you already have a screen file open, the screen reformatter will prompt you to either discard the open file or merge the open file with the new file. When you merge, you are prompted to indicate which collection to add the new screens to.

   The **Screen Reformatter** dialog box appears, indicating the number of unique screens that were added.

**Organizing Screens**

The Tree View allows you to organize screens into collections to make them easier to manage. Create a collection to group similar screens together or apply text all of them simultaneously. Each screen can only belong to one collection at a time. Screens can be reordered or moved to collections by dragging them into the correct position in the Tree View.

The Modified Screen View and Initial Screen View show one screen at a time. You can navigate to a different screen by clicking on it in the Tree View, using the arrow keys, or by using the options in the **View** menu.

**To create a new collection:**

1. In the Tree View, select the name of the collection where you want to add a sub-collection. If you want the new collection to be a top-level collection, select any collection.

2. Right-click the name of the collection and select **Add Collection**.
   
The **Add Collection** dialog box appears.

3. Type the name of the new collection in the text box.

4. If you would like the new collection to be a top-level collection, enable the **Top-level collection** option.

5. Click **Okay**.
   
The collection is added to the Tree View and you can drag-and-drop screens into the new collection.
Modifying a Screen

This section provides instructions for modifying screen captures. The following information is included:

- Renaming, Duplicating, or Deleting a Screen
- Copying Text
- Adding Text to the Modified Screen
- Resizing the Screen
- Changing the Background Color of the Screen
- Assigning an Initial Field Value
- Creating Screen Comments
- Using Screen Templates

Renaming, Duplicating, or Deleting a Screen

A screen can be renamed, duplicated, or deleted by right-clicking on it in the Tree View and selecting the appropriate option from the context menu.

Duplicating a screen may be useful when you want to create multiple reformatted screen options for the same input screen. For example, you could create two reformatted versions of the login screen for two languages. Create host profiles depending on the language used, then associate each reformatted version with a host profile.

Copying Text

You can copy text to use in the modified view. When you copy text, you can change the attributes of the text and background. You can also apply a copied region to all the screens in the current collection.

To copy:

1. Click and drag the mouse over the area you wish to copy.
When you release the left mouse button, a menu list appears.

2 Select **Copy Region** to copy the selected region to the Modified Screen View.

   The **Reformatted Screen Copy Attributes** dialog box appears.

3 If you want the selected region to appear on each screen in the collection, enable the **Add this text to all screens in collection** option.

**NOTE:** This will add the text to all the screens in the current collection but will not add the text to screens in any sub-collections.

4 If you want to use the text exactly as it appears in the original screen, enable the **Do not change the attributes** option.

   -Or-

   If you want to customize the appearance of the text, enable the **Use these custom attributes** option.

The following options become available:

- **Only use when the cursor is in the copied area** checkbox. When this option is selected, the specified text attributes will be applied only when the cursor is in the
copied region. When the cursor is not in the copied region, the text will appear but the original attributes will be used. If this option is not selected, the text will always use the specified attributes.

- **Foreground Color, Background Color** and **Weight** drop-down menus. You can edit the appearance of the text by selecting the desired colors and weight from these menus.

- **Italicized, Underlined, Crossed Out, Reversed, Blinking, Double Width, Double Width and Double Height** checkboxes. You can further alter the text appearance by enabling these checkboxes.

5 When you are finished editing the text formatting, click **OK**.

The *Reformatted Screen Copy Attributes* dialog box closes and the copied text appears in the Modified Screen View.

**Adding Text to the Modified Screen**

Add text that will appear on the modified screen or display a persistent variable.

**To add text:**

1 From the **Edit** menu, select **Add Text**.
   - Or-
   In the Modified Screen View, right-click and select **Add Text** from the context menu.
   The *Reformatted Screen Text* dialog box appears.

2 Enter your text in the **Text** box, or select **Persistent Variable** and choose a persistent variable from the drop-down menu.

3 Edit the appearance of the text with the available drop-down menus and checkboxes.

4 If you want the text to be added to all of the screens in the current collection, enable the **Add this text to all screens in collection**.

5 When you are finished editing the text, click **OK**.

The *Reformatted Screen Text* dialog box closes, and the text appears in the Modified Screen View.

To make changes to existing text, right-click the text and select **Edit Text** from the context menu.

**Changing the Font Size**

The modified screen can use a different font size than the original screen. When you use the **Edit > Font Size** option, you can change the font size for the entire screen. You also have the
option of changing the font size for all the screens for the current Client. When you apply the font size to all screens, this includes any screens imported later.

**To change the font size for a screen:**

1. Select the screen you want the change to be applied to.

2. Click **Edit > Font Size**.

   The *Modified Font Size* dialog box appears.

3. Enable the **Use this font point size** option and type the desired font size in the box.

4. If you want this font size applied to all the screens for this Client, enable the **Apply to all screens** option.

5. Click **OK**.

6. The *Modified Font Size* dialog box closes and the font size is adjusted.

**Resizing the Screen**

You can adjust the size of the modified screen to fit the screen of the target device. You can click and drag the borders of the screen in the Modified Screen View, or use the following steps to resize it by the number of rows and columns you want displayed. When you use the **Edit > Screen Size** option, you have the option of changing the screen size for all the screens for the current Client. When you apply the screen size to all screens, this includes any screens imported later.

**To resize:**

1. From the **Edit** menu, select **Screen Size**.

   - Or -

   In the Modified Screen View, right-click and select **Screen Size** from the context menu.

   The *Modified Screen Size* dialog box appears.

2. Adjust the numbers in the **Rows** and **Columns** text boxes.

3. If you want this font size applied to all the screens for this Client, enable the **Apply to all screens** option.

4. Click **OK**.

   The *Modified Screen Size* dialog box closes, and the screen size adjusts.
Changing the Background Color of the Screen

To improve the readability of the screen and improve its appearance, the screen reformatter allows you to change the background color of the screen. The change can be applied to the current screen, all screens, or the screens in the current collection.

To change the background color of the screen:
1. From the Edit menu, select Background Color.

   - Or -

   In the Modified Screen View, right-click and select Background Color from the context menu.

   The Modified Background Color dialog box appears.

2. To specify the background color for the screen, enable the Use this background color option and select the new background color from the drop-down list.

3. If you want to apply the background color to objects already on the modified screen, enable the Apply to all text and copy regions already on the screen checkbox.

4. If you want to apply the color to all the screens in the currently selected collection, or to all the screens open, enable the Apply to all screens in the collection or Apply to all screens option.

5. Click OK to apply the background color.

   The color is applied to the selected screens. To revert to using the default background color for the screen, open the Modified Background Color dialog box and enable the Use the default background color option.

Assigning an Initial Field Value

If you have a field that always or frequently requires the same value, you can assign an initial value to the field when the Client accesses that screen. For instance, if there is a Quantity field and the value is usually 1, you can populate the field with 1, and the user can avoid re-entering that value each time the screen is accessed. If the quantity changes, the user can change the value in the field.

NOTE: This option is only available with block-oriented terminal emulation, such as 5250 or 3270. It is not available for character-oriented terminals.

To assign an initial field value to a field:
1. In the Initial Screen View, right-click on the field to which you want to assign an initial value.
2 Select **Add Field Initial Value** from the context menu.

The *Initial Field Value* dialog box appears.

3 Enter the desired field value in the available text box and click **OK**.

The *Initial Field Value* dialog box closes and the initial value is assigned. The initial field value will be assigned even if the field is not copied to the modified screen.

**NOTE:** The Screen Reformatter does not verify any field data. You must ensure that the value you enter is valid for that field.

---

### Creating Screen Comments

Screen comments can help in keeping your reformatted screens organized by adding supplemental information about the screen. You can list information about the screen, any modifications or actions on the screen, or the situation the screen is created for. Screen comments are displayed in the Descriptive View. When you export a master file, the screen comments are exported with the rest of the reformating.

**To create a screen comment:**

1 Select the screen for which you want to comment.

2 Click **Edit > Screen Comments**.

   - Or -

   Right-click the Descriptive View and select **Edit Screen Comments** from the context menu.

   The *Screen Comments* dialog box appears.

3 Type the comments for the screen. When you have finished your comments, click **OK**.

   The dialog box closes and the screen comments appear in the Descriptive View.

---

### Using Screen Templates

When several modified screens will have a similar appearance, you can save a modified screen as a template to streamline the process of modifying screens. A template will contain all the modifications, actions, and verification items for a modified screen.

You can have multiple template screens simultaneously, but templates will not be exported in a master file.

**To create a screen template from an existing modified screen:**

1 Select the modified screen you want to use as a template.

2 Click **File > Save Template**.
Chapter 8: Reformatting Emulation Screens

The Save Template File dialog box appears.

3 Name the template file and click Save to save the file to the desired location.

To apply a modified screen template to a screen:

1 Select the screen you want the template applied to.

2 Click File > Load Template.

The Load Template File dialog box appears.

3 Navigate to the template file you want to apply and click Open.

The modifications, actions, and verification items in the template are applied to the current modified screen.

Verifying a Screen

In order to have the screen reformatter display the correct modified screen, you should identify verification items on the original host screen that must be matched in order for the modified screen to be displayed. Each modified screen should have verification items (or a combination of items) unique to the associated host screen so that it will display at the appropriate time.

The screen reformatter compares the verification items for each reformatted screen with the current host screen and displays the first reformatted screen with criteria that match.

The screen reformatter starts with the first modified screen in the Tree View and continues down the list until it finds a screen with matching criteria. If the first (top) screen in the Tree View only has host profile verification, the reformatter will always display that first reformatted screen for all host screens using that host profile. It will not continue to search for a better match.

Host profiles, text on the host screen, cursor position on the host screen, and fields are all items that can be used to verify a screen.

This section includes instructions for the following:

- Adding Host Profile Verification
- Adding Text Verification
- Adding Cursor Verification
- Adding Field Verification
- Ordering or Deleting Verification Items
Adding Host Profile Verification

When you use a host profile as a verification item, the modified screen will only be displayed when the specified host profile is in use. If you do not specify a host profile, the reformatted screen can be used by all host profiles. Wavelink recommends always using a host profile verification.

To add host profile verification:

1. Click **Edit > Add Verify Host Profile**.

   - Or -

   In the Initial Screen View, right-click and select **Verify Host Profile** from the context menu.

   The *Host Profile Verification* dialog box appears.

2. Select the desired host profile from the drop-down menu.

3. If you want to apply the same host profile verification to all the screens in the collection, enable the **Add this verification to all screens in the collection** option.

4. Click **OK**.

   The *Host Profile Verification* dialog box closes and host profile verification is added for the screen or screens. The name of the host profile appears in the Screen Verify Criteria in the Descriptive View.

   To remove a host profile verification item, right-click the item in the Descriptive View and click **Delete item**.

Adding Text Verification

Select text on the original emulation screen that must be verified before the modified screen is displayed to a mobile device user. The selected text will still be verified even if it is not copied to the modified screen. You can choose text that must be exactly the same, text that must be different, or text that must not change. Text verification is case-sensitive, and any spaces at end of a text selection will be discarded before verification.

To add text verification:

1. Click and drag the mouse over the text you want to verify.

2. From the context menu, select one of the following options to verify text:

   - **Verify Text Matches**. The text must match exactly or the modified screen will not be used.
• **Verify Text Different.** The text must have at least one character different or the modified screen will not be used.

• **Verify Text Doesn’t Change.** If the text changes at any point, the modified screen will no longer be used.

The text verification item appears in the Screen Verify Criteria section of the Descriptive View window.

**Adding Cursor Verification**

Select a specific cursor location on the original emulation screen that must be verified before the modified screen is displayed to a mobile device user. The selected location will still be verified even if it is not copied to the modified screen.

**To add cursor verification:**
1. Click and drag the mouse over the cursor location you want to verify.
2. From the context menu, select **Verify Cursor**.

The cursor verification item appears in the Screen Verify Criteria section of the Descriptive View window.

**Adding Field Verification**

You can select a specific field on the original emulation screen that must be verified before the modified screen is displayed to a mobile device user. The selected field’s size and location on the host screen will still be verified even if it is not copied to the modified screen.

**To add field verification:**
1. Right-click on the field you want to verify.
2. From the context menu, select **Verify Field**.

The field verification item appears in the Screen Verify Criteria section of the Descriptive View window.

**Adding Persistent Variable Verification**

When you use a persistent variable as a verification item, the modified screen will only be displayed when the specified persistent variable exists and has a value that matches the value specified. If more than one persistent variable verification is added to a modified screen, then all the persistent variable values must match in order for the reformatted screen to be used.

**To add persistent variable verification:**
1. Click **Edit > Add Verify Persistent Variable**.
   -Or-
In the Initial Screen View, right-click and select **Verify Persistent Variable** from the context menu.

The **Persistent Variable Verification** dialog box appears.

2 Select the desired persistent variable from the **Persistent Variable Name** drop-down menu. If the persistent variable name you want does not exist, then type it in the edit field of the drop-down menu. The variable name is case-sensitive, so make sure you capitalize it correctly.

3 Add the value that you want the persistent variable to have in order for the modified screen to be used. If the persistent variable is a Boolean variable, then only the values TRUE or FALSE are allowed.

4 Click **OK**.

The **Persistent Variable Verification** dialog box closes and persistent variable verification is added for the screen or screens. The name and value of the persistent variable appears in the Screen Verify Criteria in the Descriptive View.

To remove a persistent variable verification item, right-click the item in the Descriptive View and click **Delete item**.

**Ordering or Deleting Verification Items**

When you have multiple verification items on the modified screen, you can determine the order in which the items are verified.

**To arrange items in the desired order:**

1 Right-click an area that you have configured for verification in the Initial Screen View.

2 From the context menu, select one of the following options:

   • Select **Make First Item** to designate the current item as the first to be verified.
   
   • Select **Make Next Item** to designate the current item as the next verification item in the list.
   
   • Select **Make Previous Item** to designate the current action as the previous verification item in the list.
   
   • Select **Make Last Item** to designate the current item as the last be verified.
   
   • Select **Delete Item** to remove the current verification item.
Speakeasy and Scripting Support

The Screen Reformatter allows you to add support for Terminal Emulation features such as Speakeasy and scripting. When you use Speakeasy or scripting actions in the screen reformatter, the actions are considered screen actions. This section provides information about the following:

- Adding Text-to-Speech Support
- Adding Speech-to-Text in the Reformatter
- Adding Scripting Support
- Ordering Screen Actions

Adding Text-to-Speech Support

You can add text to the modified screen that will be converted into speech and played back to the mobile device user. This can be text from the host screen or text added just for the modified screen. Multiple text-to-speech actions will be processed without a pause if they are adjacent. You can also use the screen reformatter to set text-to-speech settings.

**NOTE:** Text-to-speech support is only available if you have licensed Wavelink Speakeasy software in addition to the TE Client.

To add text-to-speech:

1. Click **Edit > Add Text-to-Speech Text**.
   
   - Or -

   In the Initial Screen View, right-click and select **Add Text-to-Speech** from the context menu.

   The **Text-to-Speech Text** dialog box appears.

2. Type your text in the **Text to be spoken** text box. This box can be left empty if you only want to change the text-to-speech settings.

3. Type the desired text-to-speech settings in the **Persistent Text-to-Speech Settings to use** and/or the **Temporary Text-to-Speech Settings to use** text boxes.

   **NOTE:** Each setting must start with `tts_` and use the format `setting=value`. Multiple settings can be specified and should be separated by commas. The complete list of settings is available in the **Terminal Emulation Scripting Reference Guide**.

4. Click **OK**.
The Text-to-Speech Text dialog box closes and your text is added to the screen. It also appears in the Supporting Actions section of the Descriptive View.

**To use existing text for text-to-speech:**

1. Click and drag the mouse over the text you want to copy.

   When you release the left mouse button, a context menu appears.

2. Select **Text-to-Speech Copy**.

   The Text-to-Speech Copy dialog box appears.

3. Type the desired text-to-speech settings in the **Persistent Text-to-Speech Settings to use** and/or the **Temporary Text-to-Speech Settings to use** text boxes.

   **NOTE:** Each setting must start with `tts_` and use the format `setting=value`. Multiple settings can be specified and should be separated by commas. The complete list of settings is available in the Terminal Emulation Scripting Reference Guide.

   The Text-to-Speech action appears in the Supporting Actions section of the Descriptive View.

**Adding Speech-to-Text in the Reformatter**

You can add a speech-to-text action to the modified screen. This action converts the user’s speech into text that will be processed according to the grammar(s) specified. It can print the text to the screen as keyboard data or perform an action associated with the command.

The Local Actions and Global Actions tabs in the Speech-to-Text dialog box allow you to assign special actions to Speech-to-Text results, instead of having those results treated as keyboard data. For each Speech-to-Text result received, the Local Actions are tested first. If no Local Actions match, then the Global Actions are tested. If no Global Actions match, the result will be treated as keyboard data and use the settings configured in the General tab.

Global Actions are shared among all the screens, so changing a Global Action for one Speech-to-Text support action will change the action for all the screens. Because the Local Actions take priority over Global Actions, you can override a Global Action by creating a Local Action for the same result value. For example, you could add a Global Action that lists available commands when the user says “help”. If there is a screen where not all the commands are available, use a Local Action to override the Global Action with a list specific to that screen.

   **NOTE:** The screen reformatter supports dynamic grammar generation. Instead of using an existing grammar file, use a list of words or phrases separated by `|` (pipe character) to generate an internal grammar. For more information on editing grammar files, see the Speakeasy Reference Guide.
To add speech-to-text from the screen reformatter:

1. Click **Edit > Add Speech-to-Text**.
   - Or-
   In the Initial Screen View, right-click and select **Add Speech-to-Text** from the context menu.

   The *Speech-to-Text* dialog box appears.

2. Select the **Speech-to-Text Grammar to use** from the drop-down menu.
   - Or-
Enable the **Use more than one grammar** option and choose the desired grammars from the list box.

3 Select the action to perform with the result.

- To display the result as text on the screen, select **Print to Screen**. If you want to send a keypress after the result, select the key from the **Keypress after result** dropdown menu.

- To use the result in a script, select **Run Script**. If you want to pass parameters to the script, type the parameters in the **Parameters** text box. (Pass the speech result to the script as a parameter by typing `#R#` to represent the result.)

4 (Optional) If you would like Speakeasy to ask the device user if the result is correct, enable **Verify Result**.

   This will make a **Verify** tab appear.
Click the **Verify** tab and enter any of the following information:

- Enter a question in the **Verification Question** text box. Use `#R#` to represent the speech-to-text result.
- Enter a grammar name in the **Verification Grammar to use** text box.
- Enter a response in the **Grammar Response if Right** text box.
- Enter a response in the **Text-to-Speech if Right** text box.
- Enter a response in the **Text-to-Speech if Wrong** text box.
Chapter 8: Reformatting Emulation Screens

- Enter a number (in seconds) in the **Timeout** text box. This is how long the screen reformatter will wait for verification that it repeated the correct result. If no verification is received, the result is discarded and no action is performed.

Return to the **General** tab.

5 If you are not using a headset microphone, enable the **Delay Speech-to-Text to avoid feedback** checkbox. This will ensure that the microphone ignores input while text-to-speech actions are happening.

6 If you want to use a speech setting in the Speech-to-Text action, enter the setting in the **Speech-to-Text Settings to use** text box.

**NOTE:** Each setting must start with `stt_` and use the format `setting=value`. Multiple settings can be specified and should be separated by commas. If a value is not a number, then the Speech-to-Text engine will use the value closest to the value text description provided. The complete list of settings is available in the *Terminal Emulation Scripting Reference Guide*. Once a setting has been changed, that value will be used for future Speech-to-Text actions until it is changed again.

7 If you want to configure local or global actions for the screen, select the appropriate tab and click **Add**.

The **Result/Action** dialog box appears.

8 Type the word or phrase in the text box and then select the action that will be performed when the user says it.
Chapter 8: Reformatting Emulation Screens

NOTE: The speech to text results must be an exact match for the action to be performed. Speech-to-text results are case-sensitive.

- **Replace the result with this text.** Replaces the speech-to-text result with the provided text. When this replacement is made, the Keypress after result value of the General tab is not used, so if you want to use an additional key press you should include it here. For instructions on determining the value of a key press, see "Performing a Keyboard Test" in the TE Client User Guide.

  Use \ followed by the 4-digit hexadecimal number to specify a Telnet key press, and \U followed by the 4-digit hexadecimal number to specify a Unicode character. If you want to actually output a backslash character, use \\.

  For example, to replace the result “euro” with “€” followed by a VT Enter key press, use this value:

  \U20ac\000d

- **Perform a key press.** Replaces the speech-to-text result with a key press. You can use the name of the key (such as F3 or Enter) or the hexadecimal number.

- **Start a script.** Replaces the result with a script. Use an existing script or click Edit Scripts to launch the Script Editor.

- **Pause Speech-to-Text while the script is running.** Disables speech-to-text for the screen reformatter while the script is running. Enable this option if the script is also using speech-to-text so that only one application is trying to use speech-to-text at a time.

- **Perform an IDA action.** Replaces the result with the a standard action. Many of these actions are also available other ways, such as by writing a script or using a key press value.

- **Set a Speech-to-Text or Text-to-Speech setting.** Replaces the result by changing the Speakeasy settings for the Client. Each setting must start with stt_ or tts_ and use the format setting=value. If a value is not a number, then the engine will use the value closest to the value text description provided. The complete list of settings is available in the Terminal Emulation Scripting Reference Guide.

  You can change multiple settings with a comma-delimited list (no spaces). The list must contain only Speech-to-Text settings, or only Text-to-Speech settings. You cannot mix the two types of settings. If you need to do that, then create and call a script instead of using this option.

- **Standard Beep.** Replaces the result with a standard TE beep. If the beep has been modified in the emulation parameters, the modified beep will be used.
• **Error Beep.** Replaces the result with a TE error beep. If the beep has been modified in the emulation parameters, the modified beep will be used.

• **Restart the supporting actions for this screen.** Replaces the result with a restart of the supporting actions for the screen. Any text-to-speech actions and script actions will be repeated.

• **Cancel the Speech-to-Text.** Interprets the result as a command to stop the Speakeasy listening engine while the user is on the current screen. The engine will begin listening again when the user changes screens.

• **Do Nothing.** Ignores the result. This option is useful if a grammar is being used that can return results that don’t apply to the current screen.

Click **OK** to save the changes to the Local/Global Action and return to the *Speech-to-Text* dialog box.

9 When you have configured speech-to-text for the modified screen, click **OK**.

The *Speech-to-Text* dialog box closes and the speech-to-text action is added to the modified screen.

If you need to modify the speech-to-text action, right-click the action in the Descriptive View and select **Edit Speech-to-Text**.

**Adding Scripting Support**

Use the screen reformatte to launch Speakeasy scripts when the modified screen is first displayed. The script can provide additional functionality to the modified screen.

To add a script:

1 Click **Edit > Add Scripting Support**.

   - Or -

   In the Initial Screen View, right-click and select **Add Scripting Support** from the context menu.

   The *Scripting Support* dialog box appears.

2 Select the desired script from the **Script to launch** drop-down menu. If you want to pass specific parameters to the script, type them in the **Parameters** text box separated by commas.

**NOTE:** The **Script to launch** drop-down menu only displays scripts that have been saved in the Script Editor. For more information about Terminal Emulation scripting, see the *Wavelink Terminal Emulation Scripting Reference Guide*. 
3 Select how the screen reformatter will handle the script:

- If you want to ensure that the script does not run multiple times, enable the **Don’t launch the script if it is already running** checkbox.

- If you want the script to abort when the modified screen is no longer in use, enable the **Stop the script when reformatting changes** option.

- If you want the screen reformatter to wait until the script has completed before it proceeds to the next action for the screen, enable the **Wait for the script to finish before performing the next supporting action**.

4 Click **OK**.

The *Scripting Support* dialog box closes and the script is added to the Supported Actions listed in the Descriptive View.

**Ordering Screen Actions**

When you have multiple actions on the modified screen, you can determine the order in which the actions occur. The actions are listed in the Descriptive View in the Supported Actions section. Supported screen actions are Speakeasy and scripting actions. You should list the text-to-speech actions before any speech-to-text actions.

*To arrange actions in the desired order:*

1 Select the desired action in the Modified Screen View.

2 Click the **Edit** menu.

   - Or-

   Right-click in the Initial Screen View.

   A menu list appears.

3 Select one of the following options:

   - **Make First Action** to designate the current action as the first action to be performed.
   
   - **Make Next Action** to designate the current action as the next action in the list.
   
   - **Make Previous Action** to designate the current action as the previous action in the list.
   
   - **Make Last Action** to designate the current action as the last action to be performed.
   
   - **Delete Action** to remove the current action.
Deploying Reformatted Screens

Once you have finished modifying your screens, click **Save** to save your screens and exit the Screen Reformatter. The TE Client will update with the new screens the next time the device syncs.

Exporting Screens

Once you have modified screens for a specific Client, you can export the screens in order to use them for a different Client. Export screens as either a screen capture or as a master file. A master file contains the original screens and all modifications, scripting and Speakeasy actions, and comments. A screen capture contains only the original screens.

- Exporting a Master File
- Exporting a Screen Capture File

**NOTE:** If you want to copy reformatted screens and the associated scripts or settings from one device configuration (or Avalanche package) to another, you can export them all together. For instructions, see *Exporting and Importing Settings* on page 9.

Exporting a Master File

Once you have modified screens for a specific Client, you can export the screens in order to use them for a different Client. A master file is one that contains modified screens, along with the original screen capture information. You can create a master file by exporting all the screens you have modified or by exporting a collection.

To export:

1. Click **File > Export Collection to Master File** to export the current collection.
   - Or-

   Click **File > Export Master File** to export all the current screens. If you have not saved your modifications, the *Screen Reformatter* dialog box appears, asking if you would like to save your changes. Click **Yes**.

   The *Export Master File* dialog box appears.

2. Navigate to the location where you would like to save the file, and enter a name in the **File Name** text box.

3. Click **OK**.

   The *Export Master File* dialog box closes and the master file is saved.
Exporting a Screen Capture File

A screen capture file only contains the original emulation screens. You can merge screen capture files and then save them as a single file, or delete unnecessary screens and re-save the capture file so it is smaller. The file can then be used at a different location or for a different TE Client.

To export screens to a screen capture file:

1. Click **Tools > Export Screen Capture**.
2. The *Export Screen Capture* dialog box appears.
3. Navigate to the location where you want to save the file and type a name for the screen capture file. Click **Save**.

The file can be opened and modified at other locations or for other Clients.
Chapter 9: Using the TE Client

After you have installed and configured the TE Client on a mobile device, you can connect to the emulation host. This section provides information about using the TE Client on the mobile device. It includes the following information:

- Launching the TE Client
- Creating an Emulation Session
- Working with Multiple Concurrent Emulation Sessions
- Using the Virtual Emulation Keyboard
- Using Screen Panning
- Using ActiveText
- Using the TE Client Diagnostics Utility
- Using the TE Client Options Menu
- Launching the TE Client Using Command Line Arguments

Launching the TE Client

Depending on the method that you used to install the TE Client, there are different options for launching the TE Client.

If you installed the TE Client through Microsoft ActiveSync or another third-party application, then you will be able to launch the application from the Windows CE Start menu or from the desktop.

If you installed the TE Client using Avalanche, then you will also be able to launch the TE Client from the Start menu or from the Avalanche Enabler interface on the device.

Use the Options menu to exit the TE Client. Depending on the configuration of the Client, you may be required to supply an exit password before you can exit.

NOTE: By default, the TE Client is not configured with an exit password. For more information about configuring an exit password for the TE Client, see Configuring Passwords on page 143.

To launch the TE Client from the Start menu:

1. On the mobile device, access Start > Programs.
2. In the Programs folder, double-click the TelnetCE Client shortcut icon.
The TE Client launches on the mobile device and displays the default screen.

![TE Client Default Screen](image)

**To launch the TE Client from the Avalanche Enabler:**

1. On the mobile device, launch the Avalanche Enabler.

2. If the Programs view is not available in the Avalanche Enabler, access the **View** menu and enable the Programs view.

   The TE Client shortcut icon appears in the Programs view of the Avalanche Enabler.
3 In the Programs view of the Avalanche Enabler, double-click the TelnetCE icon. The TE Client launches on the mobile device and displays the default screen.

To exit and close the TE Client:
- From the TE Client, select Options > Exit.
If you have configured the TE Client with an exit password, the Input Password dialog box appears. Type the exit password and tap OK.

The TE Client closes.

Creating an Emulation Session

The TE Client is designed to connect a mobile device to an emulation host. This section provides the following information:

- Initiating an Emulation Session
- Disconnecting an Emulation Session

Initiating an Emulation Session

Use the TE Client to initiate an emulation session with any host for which you have configured a host profile.

NOTE: For more information about host profiles and configuring host profiles for the TE Client, see Configuring Host Profiles on page 15.

To initiate an emulation session with a host:

1. On the mobile device, launch the TE Client.
   
   The TE Client displays the default screen.

2. Press Enter.
   
   The Select Host dialog box appears.
Chapter 9: Using the TE Client

Select Host Dialog Box

NOTE: If you have configured only one host profile for the TE Client, the Select Host dialog box does not appear. Instead, the TE Client automatically attempts to connect to the host for which you have configured the host profile.

3 In the Select Host dialog box, select the host to which you want to connect and click OK.
   The TE Client attempts to establish an emulation session with the host.

NOTE: If the client does not have a license, then the Authorizing Terminal dialog box appears. For more information about TE Client licensing, see Licensing the TE Client on page 10.

Disconnecting an Emulation Session

Use the TE Client Options menu to disconnect from an active emulation session.

NOTE: If you have multiple sessions, you must switch to the session that you want to disconnect before you can disconnect. You can only disconnect the active session.

To disconnect from an emulation session:
1 Access the Options menu.
2 In the Options menu, select Disconnect Session [n]-[name], where:
   • [n] is the session number that you want to disconnect.
• [name] is the name of the host you want to disconnect.

The session that you selected is terminated.

Working with Multiple Concurrent Emulation Sessions

Although the TE Client only has one session active at a time, it can maintain connections to multiple hosts simultaneously. This section provides the following information:

• Allowing Multiple Concurrent Sessions
• Initiating an Additional Emulation Session
• Switching Between Active Emulation Sessions

Allowing Multiple Concurrent Sessions

By default, the TE Client is configured to allow a user to engage in only one emulation session at a time. However, the Client can support up to four concurrent emulation sessions. (These may include sessions to the same host or to different hosts.) To provide for more than one active emulation session, you must configure the TE Client to allow multiple concurrent sessions.

When the TE Client is configured to support multiple sessions, then multiple connection options appear in the TE Client Options menu.
To modify the maximum number of concurrent sessions:

1. Access the Configuration Manager. (For information about using the Configuration Manager, see Emulation Parameters on page 37.)

2. Locate the Emulation > Common > Number of Sessions parameter.

3. Use the Number of Sessions dialog box to specify the maximum number of sessions. You can have up to 4 sessions.

4. Click OK.

5. Save the new configuration.

6. Close the Configuration Manager and download the new configuration to the mobile device.

Initiating an Additional Emulation Session

If the TE Client is engaged in one or more emulation sessions, you may initiate an additional emulation session from the Options menu.

To initiate an additional emulation session:

1. Ensure that the TE Client is configured to allow multiple concurrent sessions.

2. Access the TE Client Options menu.

   The Options menu displays the available sessions (between 1 and 4) and indicates which sessions are connected to a host and which are unconnected.

3. From the Options menu, select an unconnected session that you want to use to connect to the host.
The TE Client now displays the default screen. (The default screen prompts you to press Enter to connect to a host.)

4 Press Enter.

The Select Host dialog box appears.

5 Use the Select Host dialog box to select the host with which you want to establish an emulation session.

6 Select OK.

The TE Client attempts to connect to the host that you have selected.

**Switching Between Active Emulation Sessions**

If the TE Client is engaged in more than one emulation session, use the Options menu to switch between the sessions.

To switch between emulation sessions:

1 In the TE Client, access the Options menu.

2 In the Options menu, select the active session that you want to view.
Chapter 9: Using the TE Client

Using the TE Client

Switching to a Different Emulation Session

The TE Client switches the view to the emulation session that you selected.

**NOTE:** You can also use the **Next Sess** or **Prev Sess** keys in the virtual emulation keyboard to switch between sessions. For information about accessing the virtual emulation keyboard, see Using the Virtual Emulation Keyboard on page 106.

Using the Virtual Emulation Keyboard

The TE Client has a default virtual emulation keyboard or you can configure your own virtual keyboards. You can access the keyboard through the TE Client **Options** menu.

The Client displays a keyboard specific to the current emulation type. The following sections provide information on the keys for the virtual keyboards:

- **Using the Default Virtual Emulation Keyboard**
- **Using the 5250/3270 Virtual Emulation Keyboard**
- **Using the VT/HP Virtual Emulation Keyboard**
- **Using the WEB Virtual Emulation Keyboard**

If there is no active session, then the default virtual emulation keyboard appears.

**To access the virtual emulation keyboard:**

1. Access the TE Client **Options** menu.
2 Select View > Emulation Keyboard.

The virtual emulation keyboard appears.

**Using the Default Virtual Emulation Keyboard**

The following figure shows the default TE Client virtual emulation keyboard.

<table>
<thead>
<tr>
<th>TermConfig</th>
<th>Prog Info</th>
<th>Next Sess</th>
</tr>
</thead>
<tbody>
<tr>
<td>HostConfig</td>
<td>Prev Sess</td>
<td></td>
</tr>
<tr>
<td>KeyCks</td>
<td>Quiet</td>
<td>Diacs</td>
</tr>
</tbody>
</table>

The following list describes the functions of the keys in the default virtual emulation keyboard:

**TermConfig** Allows you to access and configure the emulation parameters for a specific host profile.
**Prog Info**  Shows/hides the following information about the mobile device:

- TE Client version information
- MAC address
- IP address
- ESSID

**Next Session**  Cycles to the next TE Client session.

**Host Config**  Allows you to access and configure the host profiles for the TE Client.

**Prev Session**  Cycles to the previous emulation session.

**Keyclks**  Turns keyclicks on/off.

**Quiet**  Turns quiet mode on/off.

**Diags**  Allows you to access the TE Client diagnostic tools.

**Enter**  Connects the session.

**Close**  Disconnects the session. (Only available when the session is connected.)

### Using the 5250/3270 Virtual Emulation Keyboard

The following figure shows the TE Client virtual emulation keyboard for 5250/3270 emulation.

![5250/3270 Virtual Emulation Keyboard](image)

The following list describes the function of the control keys that appear at the bottom of the virtual emulation keyboard:

**Alpha**  Displays the alpha keys for 5250/3270 emulation, including:

- a - z
- Tab, Caps Lock, Shft, Res, Backspace, FieldExit, Enter, Space, Alt
Chapter 9: Using the TE Client

Num Displays the numeric keys for 5250/3270 emulation, including:
- 0 - 10
- Mathematical symbols
- Reset, Backspace, FieldExit, Enter, Arrow Keys
- Tab, Shift, Space

Func1 Displays the function keys for 5250/3270 emulation, including:
- F1 - F24
- Roll Up, Roll Down, Enter

Func2 Displays other function keys for 5250/3270 emulation, including:
- Dup, Print, Clear
- Attn, Help, Home
- Insert, Roll Up, Roll Down
- Delete, SysRq, ErInp, Reset

Punc Displays punctuation characters for 5250/3270 emulation, including:
- Various punctuation and mathematical symbols
- Reset, Field Exit, Enter

Alt Displays the default virtual emulation keyboard. For information about the keys in the default virtual emulation keyboard, see Using the Default Virtual Emulation Keyboard on page 107.

Off Hides the virtual keyboard.

Using the VT/HP Virtual Emulation Keyboard

The following figure shows the TE Client virtual emulation keyboard for VT/HP emulation.

```
<table>
<thead>
<tr>
<th>Shift</th>
<th>Esc</th>
<th>q</th>
<th>w</th>
<th>e</th>
<th>r</th>
<th>t</th>
<th>y</th>
<th>u</th>
<th>i</th>
<th>o</th>
<th>p</th>
<th>&lt;--</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl</td>
<td>Tab</td>
<td>a</td>
<td>s</td>
<td>d</td>
<td>f</td>
<td>g</td>
<td>h</td>
<td>j</td>
<td>k</td>
<td>l</td>
<td>Enter</td>
<td></td>
</tr>
<tr>
<td>Alt</td>
<td>Caps</td>
<td>z</td>
<td>x</td>
<td>c</td>
<td>v</td>
<td>b</td>
<td>n</td>
<td>m</td>
<td>Space</td>
<td>↑</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Alpha</td>
<td>Num</td>
<td>Func</td>
<td>Punc</td>
<td>Cfg</td>
<td>Off</td>
<td>←→</td>
<td>↓</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

TE Client VT/HP Virtual Emulation Keyboard
The following list provides information about the various control keys that appear at the bottom of the VT/HP virtual emulation keyboard.

**Alpha**
Displays the alpha keys for VT/HP emulation, including:
- a - z
- Esc, Caps lock, Tab, Space, Enter, Backspace
- Shft, Ctl, Alt

**Num**
Display the numeric keyboard for VT/HP emulation, which contains the following keys:
- 0 - 9
- Esc, Tab, Ins, Rem, Backspace, Enter, Space
- Shft

**Func**
Displays the function keys for VT/HP emulation, including:
- F1 - F10
- Esc, Tab, Prev, Next, Find, Sel, Space, Backspace, Enter
- Shft, Ctl, Alt

**Punc**
Display the punctuation keys for VT/HP emulation, including:
- Punctuation Keys
- Backspace, enter, Space

**Cfg**
Display the default virtual emulation keyboard. For information about the keys in the basic emulation keyboard, see Using the Default Virtual Emulation Keyboard on page 107.

**Off**
Hides the virtual keyboard.

**Arrow Keys**
Moves the cursor in the direction of the arrow key that you press.

**Using the WEB Virtual Emulation Keyboard**
The following figure shows the TE Client virtual emulation keyboard for WEB emulation.
The following list describes the function of the keys in the WEB virtual emulation keyboard.

**Back**  Returns the browser to the previous web page.

**Fwd**  Returns to the screen displayed before **Back** was selected.

**Stop**  Stops the web page from loading.

**Refresh**  Reloads the current web page.

**Home**  Returns the browser to the specified home page.

**Prev Sess**  Cycles to the previous emulation session.

**Next Sess**  Cycles to the next emulation session.

**Close**  Disconnects the session. (Only available when the session is connected.)

**Key Clicks**  Turns key clicks on/off

**Quiet**  Turns quiet mode on/off.

**Info**  Shows/hides the following information about the mobile device: TE Client version information, MAC address, IP address, ESSID.

**Diags**  Allows you to access the TE Client diagnostic tools.

**Alpha**  Displays the alpha keys for WEB emulation, including:

- a-z
- Shift, Ctrl, Alt
- Esc, Tab, Caps, Enter, Space
**Num** Displays the numeric keyboard for WEB emulation, including:
- 0-9
- Shift
- Esc, Tab, Ins, Enter, Space

**Func** Displays the function keys for WEB emulation, including:
- F1-F24

**Punc** Displays the punctuation keys for WEB emulation, including:
- Punctuation keys
- Enter, Space

**Cfg** Display the virtual emulation keyboard.

**Off** Hides the virtual keyboard.

**Arrow Keys** Moves the web page up and down or from side to side.

---

**Using Screen Panning**

By default, the screen panning feature of the TE Client is enabled.

The screen panning feature of the TE Client allows a user to tap-and-drag the stylus to move around the emulation screen.

Screen panning has two modes of operation:

- **Standard.** By default, standard screen panning is enabled on the TE Client. When standard screen panning is enabled, the screen scrolls in the direction that the user drags the stylus across the screen. Standard screen panning simulates the effect of dragging the display of the mobile device over the emulation screen.

- **Reversed.** When reversed screen panning is enabled, the screen scrolls in the opposite direction that the user drags the stylus. Reverse screen panning simulates the effect of dragging the emulation screen beneath a fixed view port (that is, mobile device display).

---

**NOTE:** For information about configuring screen panning, see Configuring Screen Panning on page 149.
Using ActiveText

By default, the ActiveText feature of the TE Client is enabled.

ActiveText allows the TE Client to identify menu items and functions in an emulation screen and convert them to interactive objects that a user can double-click to execute.

When a string of text is turned into ActiveText, a user can perform the following actions on the ActiveText object:

- **Single-click.** A single click highlights the string of text and indicates that it has become an ActiveText object.
- **Double-click.** A double-click executes the menu item or the function that has been converted to an ActiveText object.

You can configure the TE Client to recognize two types of text strings that will be converted to ActiveText objects:

- **Simple Number Menu Item**
- **AS/400-Style Function Key**

**NOTE:** For information about configuring ActiveText, see Configuring ActiveText on page 150.

Simple Number Menu Item

The TE Client can recognize numbered options in a menu and convert them to an ActiveText object.

The TE Client recognizes a string of characters in the following format as a simple number menu item:

- A beginning of line or a space
- A number (a string of digits)
- A period (.)
- A space
- A non-space character

For example, the TE Client would convert the menu item **90. Sign Off** in an emulation to ActiveText. The user could then double-click the ActiveText to invoke the **90. Sign Off** menu option.
AS/400-Style Function Key

The TE Client can recognize AS/400-style function key commands in an emulation screen. The TE Client recognizes the following string of characters as an AS/400-style function key:

- A beginning of line or a space
- The character F
- A number (string of digits)
- An equal-to character (=)
- A non-space character

For example, the Client would convert the function key command F3=Exit to ActiveText. The user could then double-click the ActiveText to invoke the F3=Exit command.

Using the TE Client Diagnostics Utility

The TE Client diagnostics utility allows you to find scan codes for specific character sequences and verify scan data:

- Performing a Keyboard Test
- Using the TE Client Options Menu
- Performing a Scan Test

The diagnostics utility is accessed through the TE Client virtual keyboard.

To access the diagnostics utility:
1. In the TE Client, access the virtual emulation keyboard.
2. In the virtual keyboard, click Diags.

**NOTE:** Diags appears in the default virtual emulation keyboard. For VT/HP emulation, Diags appears in the Cfg display of the virtual keyboard. For 5250/3270 emulation, Diags appears in the Alt display of the virtual keyboard.

The Program Diagnostics screen appears in the TE Client.
3 Select one of the options in the Program Diagnostics screen:

- Press **K** to perform a keyboard test, which allows you to obtain scan codes for the external keyboard and the TE Client virtual keyboard.

- Press **S** to perform a scan test, which allows you to determine the type of barcode for a scan.

- Press **W** to perform a Windows keyboard test, which allows you to obtain scan codes for the Windows virtual keyboard.

- Press **Q** to quit the diagnostics utility.

### Performing a Keyboard Test

Use the TE Client to obtain scan codes for the external keyboard and the TE Client virtual keyboard.

**To perform a keyboard test:**

1 Ensure that you have an active VT/HP or 5250/3270 emulation session.

**NOTE:** An active session is required to test the TE Client virtual keyboard. The virtual keyboard displays keys based on the current emulation session type.

2 Use the TE Client virtual keyboard to access the Program Diagnostics screen.

3 Press **K** to begin a keyboard test.
The *Keyboard Test* screen appears.

4 Use the external keyboard or the virtual keyboard to submit a character sequence to the TE Client.

The TE Client displays the scan code for the character sequence.

Performing a *Keyboard Test*

5 When you are finished, press `Q` to return to the diagnostics utility.

**Performing a Windows Keyboard Test**

Use the TE Client diagnostics utility to obtain scan codes for the Windows virtual keyboard.

To use the diagnostics utility to obtain Windows scan codes:

1 In the TE Client, access the diagnostics utility.

   The *Program Diagnostics* screen appears.

2 Press `W` to begin a Windows keyboard test.

   The *Windows Keyboard Test* screen appears.

3 Access the Windows virtual keyboard.

4 Press a character sequence in the Windows virtual keyboard.

   The diagnostics utility displays the scan code for the character sequence.
Performing a Windows Keyboard Test

When you are finished, press Q to return to the diagnostics utility.

Performing a Scan Test

Use the TE Client diagnostics utility to perform a scan test. A scan test allows you to verify the type and value of scanned data. The scan test utility does not process any scan handlers, scan identifiers, or pre- or post-amble strings. However, scan identifiers that you have configured are added to the scan.

To use the diagnostics utility to perform a scan test:

1. In the TE Client, access the diagnostics utility.

   The Program Diagnostics screen appears.

2. Press S to begin a scan/MSR test.

   The Scan/MSR Test screen appears.

3. Use the scanner on the mobile device to perform a test scan.

   The Scan/MSR Test screen displays the results of the scan.
When you are finished, press Q to return to the diagnostics utility.

Using the TE Client Options Menu

This section provides a description of each option in the TE Client Options menu. The availability of some options depends on the current session.

**Connect Session [n]** Uses the current session [n] to initiate a emulation connection with a host.

**Disconnect Session [n]** Disconnects the current session [n].

**Session [n] - [name]** Switches between sessions, where:

- [n] indicates the session number.
- [name] indicates the name of the host.
- `unconnected` indicates that the session is not currently in use.

**Web > Back** Returns to the previous web page.

**Web > Forward** Goes to the screen before Back was used.
Chapter 9: Using the TE Client

**Web > Stop**  
Stops the web page from loading.

**Web > Refresh**  
Reloads the current web page.

**Web > Home**  
Returns the browser to the specified home page.

**Web > Text Size**  
Changes the text size. The available options are: Largest, Larger, Medium, Smaller, Smallest.

**Scripting > Execute Script**  
Activates a script.

**Scripting > Cancel Script**  
Stops a script that is running.

**Scripting > Start Capture**  
Begins capturing keypresses and mouse/cursor movements for script generation.

**Scripting > Stop Capture**  
Ends script capturing.

**Scripting > Verify Screen Contents**  
Pauses the script and wait for a screen update.

**Scripting > Save Cursor Position**  
Pauses the script and wait for the specified cursor position.

**Scripting > Set Field Data ID**  
Sets the field data ID.

**Configure > Host Profiles**  
Configures host profiles for the TE Client.

**Configure > Emulation**  
Configures emulation parameters for the TE Client.

**Configure > Scripting**  
Edits scripts for the TE Client.

**Configure > Authorization**  
Configures licensing for the TE Client.

**Configure > Localization**  
Configures localization for the TE Client.
Configure > Resources
Accesses the Resource Editor.

View > Emulation Keyboard
Shows/hides the virtual emulation keyboard.

View > Numeric Keyboard
Shows/hides the numeric keyboard.

View > Current Config
Shows the display settings for the emulation session.

Logging > Screen Capture
Toggles screen capturing on and off.

About
Provides information about the TE Client.

Exit
Exits and closes the TE Client. Depending on the configuration of the TE Client, you may need to supply an exit password.

Launching the TE Client Using Command Line Arguments

The TE Client supports two command line arguments: one that launches the Client, and one that creates a host profile to connect to a specific URL.

To launch the TE Client from a command prompt:
1. Open a command prompt.
2. Type `TelnetCE /profile` followed by the name of the host profile to which you want to connect.
3. Press Enter.

   The emulation session is launched and connected to the specified host profile.

To create a host profile from a command prompt:
1. Open a command prompt.
2. Type `/url` followed by the URL to which you want to connect.
3. Press Enter.

   A new emulation session is launched, and a new host profile is created.
Chapter 10: Industrial Browser (WEB Emulation)

This section provides information about using the Terminal Emulation (TE) Industrial Browser. The Industrial Browser allows you to access web-based applications from a mobile device. The Industrial Browser is included in the TE Client 6.0 and newer. It functions on the following platforms: PocketPC 2003, Windows Mobile 5.0, Windows 2000/XP, and Windows CE .NET 4.2/5.0.

The Industrial Browser supports a list of META tags and IDA commands that allow you to develop custom web pages that enable specific functionality in the Industrial Browser. For information on developing web pages for the Industrial Browser, see the Industrial Browser Reference Guide.

In order to use WEB Emulation, you must configure a host profile with the address of the web page(s) you want the Industrial Browser to access. For information on configuring host profile settings for WEB emulation, see Host Profile Configuration Options on page 17.

This section provides information about using the TE Industrial Browser, including the following:

- Basic Navigation
- Specifying the Home Page

Basic Navigation

The TE Industrial Browser interface provides basic commands for navigating web pages.

To navigate within the Industrial Browser:
1. Create a WEB emulation session.
2. Tap and hold on the screen.
   - A context menu appears.
3. From this menu, you can select from the following options:

   - **Back** Go back one page.
   - **Forward** Go forward one page.
   - **Stop** Stops the web page from loading.
   - **Refresh** Reloads the current web page.
   - **Home** Returns the browser to the specified home page.
Text Size Displays a menu with the following text size options: Largest, Larger, Medium, Smaller, Smallest

Specifying the Home Page

The home page is the first page users will see when using the Industrial Browser; it is also the page users will be returned to when they select Home. The home page will be the location you set up in the host profile for WEB emulation. This can either be an IP address or a specific web address. For more information, see Host Profile Configuration Options on page 17.
Chapter 11: Avalanche Integration

Additional features are available for the TE Client when you choose to install the TE Client using Avalanche. Avalanche-installed TE Clients offer the following features:

- **Session Monitor.** Allows you to monitor and to take control of the TE Client remotely from the Avalanche Console.
- **Real-Time Statistics.** Allows you to view real-time statistics, including session length and number of scans, from the Avalanche Console.

To take advantage of the Avalanche features of the TE Client, your Avalanche environment must meet the following requirements:

- Avalanche Manager (3.4 or newer for real-time statistics, 3.5 or newer for Session Monitor), Avalanche MC, or Avalanche SE
- Avalanche Enabler 3.x (or newer), installed and licensed on the device
- TE Client 5.x (or newer), installed and licensed on the device

Session Monitor

The Session Monitor utility allows you to view the TE Client session from the Avalanche Console. Session Monitor includes an override feature that allows the Avalanche user to take control of the TE Client. Session Monitor also includes a logging feature that allows you to create a trace for emulation sessions.

This sections provides the following information:

- Configuring Session Monitor
- Launching Session Monitor
- Session Override
- Tracing Sessions

Configuring Session Monitor

After you have added the TE Client software package to an Avalanche software profile, configure the following Session Monitor parameters:

- **Session Monitor Address.** These are the IP addresses of computers that the TE Client allows to do session monitoring. If no addresses are specified, the TE Client allows session monitoring from any computer.
• **Session Monitor Override Timeout.** This is the maximum number of minutes that Session Monitor is allowed to override the session. After the time expires, the override setting is disabled and control returns to the Client device. The default time-out for override mode is set to 0 (never). This means the override mode will never time-out and the Client regains control only if override mode is disabled manually.

• **Session Monitor Password.** This is the password required for Session Monitor connections. The password is loaded in the emulation parameters file and is never entered by the user. It has a 63-character limit. If no password is entered, the TE Client will not accept Session Monitor connections.

• **Session Monitor Port.** This is the port that the TE Client listens on for Session Monitor connections.

**To configure Session Monitor:**

1. Launch the Avalanche Console.
2. In the Profiles tab, select the software profile that contains the TE Client package.
3. In the Software Packages list, select the TE Client software package and click **Configure**.
   The **Configure Software Package** dialog box appears.
4. Select **Emulation Parameters** and click **Launch**.
   The Configuration Manager launches.
5. Navigate to **Emulation > Session Monitor**.
6. Double-click the Session Monitor options to change the parameters.

**NOTE:** The Session Monitor Password is the only required configuration. The other parameters are optional configurations.

7. Once you have configured the Session Monitor parameters, save your changes.
8. Close the configuration utility.
9. Perform an Avalanche update to download the new configuration to the mobile device.

**Launching Session Monitor**

You can launch Session Monitor from the Avalanche Console.

**To launch Session Monitor**

1. Launch the Avalanche Console.
2. From the Mobile Device Inventory, right-click the device you want to monitor.
3. From the context menu that appears, select **Session Monitor**.
The Session Monitor screen opens and connects to the session. The yellow-lined box represents what the device user can see.

**NOTE:** You must have a Session Monitor password configured in the emulation parameters, or the Session Monitor option will not be available.

![Session Monitor Screen](image)

**NOTE:** If both the mobile device and the Avalanche PC have SSL support installed, the Session Monitor traffic will be encrypted.

### Session Override

When you use session override, only the user at the Avalanche Console will be able to control the TE Client.

**To enable override mode**

- In Session Monitor, click **Monitor > Session Override**.
The session remains in override mode until the override timeout minutes expire or until the Session Monitor user disables the session override option.

**Tracing Sessions**

Use the *Log File Settings* dialog box to configure the Session Monitor log file to trace Session Monitor sessions. A trace will track all the network traffic between the Client and the host.

**To trace a session:**

1. In Session Monitor, click **File > Log To File**.
2. Configure the log file settings.
3. In the **Log File Path** text box, enter the path to the directory where you want to save the log file.
4. Click **OK**.

The log file is saved as *sessionlog.txt* in the directory specified in **Log File Path** text box. If *sessionlog.txt* already exists, the log file will attempt to save as *sessionlog2.txt*, *sessionlog3.txt*, etc. until it finds a non-existing file name in the specified log file path.
Real-Time Statistics

The TE Client periodically transmits emulation-specific information to Avalanche Console. The Avalanche Console displays the information it receives in the Properties tab of the Mobile Device Details dialog box for the mobile device.

The Avalanche Console displays emulation session information including the current TE Client version, the mobile device battery power, SSL support and use, session connect time, and running time of the current session.

**NOTE:** To use real-time statistics with the TE Client, you must have Avalanche configured to allow collection of statistics. This may include options on the Enabler and options set at the Avalanche Console for the mobile device server.

By default, the TE Client transmits statistical information to the Avalanche server every five minutes (300 seconds). You can modify this RealTimeStatsInterval property in the Properties tab of the Mobile Device Details dialog box.

This section provides the following information:

- Viewing Real-Time Statistics
- Modifying Real-Time Statistics

Viewing Real-Time Statistics

You can view the real-time statistics from the Properties tab of the Mobile Device Details dialog box.

To view the statistics:

1. Launch the Avalanche Console.

2. From the Mobile Device Inventory, right-click the device and select **Mobile Device Details**.

   The Mobile Device Details dialog box opens.

3. Click the **Properties** tab.

   The Properties tab contains a number of entries specific to the TE Client.

The following list describes the TE Client statistics that are displayed in the Properties tab.
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>General &gt; RealTimeStatsInterval</td>
<td>Indicates how often the Avalanche Enabler sends real-time statistics information to the server. The interval is measured in seconds.</td>
<td>Default: 300 seconds</td>
</tr>
<tr>
<td>Telnet &gt; Average Time Total</td>
<td>Indicates the length of time the session statistics are tracked.</td>
<td>Default: 600 seconds</td>
</tr>
<tr>
<td>Telnet &gt; Average Time Display</td>
<td>Indicates the interval time for barcode, MSR, and RFID scans and transactions. The default setting (60 seconds) means that scans display as a number of scans per minute. If you change this to property to 120 seconds, the scans display as number of scans per two minutes.</td>
<td>Default: 60 seconds</td>
</tr>
<tr>
<td>(Realtime) &gt; Time Running</td>
<td>Displays the current running time for the TE Client.</td>
<td></td>
</tr>
<tr>
<td>(Realtime) &gt; Version</td>
<td>Displays the current version of the TE Client.</td>
<td></td>
</tr>
<tr>
<td>(Realtime) &gt; SSL Supported</td>
<td>Indicates whether SSL is supported.</td>
<td></td>
</tr>
<tr>
<td>(Realtime) &gt; SSH Supported</td>
<td>Indicates whether SSH is supported.</td>
<td></td>
</tr>
<tr>
<td>(Realtime) &gt; Battery Power</td>
<td>Indicates the remaining battery power of the mobile device.</td>
<td></td>
</tr>
<tr>
<td>(Realtime) &gt; Session &lt;n&gt; Connect Time</td>
<td>Displays the amount of time the session has been running, where &lt;n&gt; indicates the session (1–4).</td>
<td></td>
</tr>
<tr>
<td>(Realtime) &gt; Session &lt;n&gt; SSL in Use</td>
<td>Indicates whether the session is using SSL, where &lt;n&gt; indicates the session (1–4).</td>
<td></td>
</tr>
<tr>
<td>(Realtime) &gt; Session &lt;n&gt; Barcode Scans</td>
<td>Displays the number of barcode scans per &lt;n&gt; seconds for the session, where &lt;n&gt; indicates the session (1–4) and &lt;n&gt; indicates the time set in the Telnet Average Time Display property.</td>
<td></td>
</tr>
<tr>
<td>(Realtime) &gt; Session &lt;n&gt; MSR Scans</td>
<td>Displays the number of MSR scans per &lt;n&gt; seconds for the session, where &lt;n&gt; indicates the session (1–4) and &lt;n&gt; indicates the time set in the Telnet Average Time Display property. MSR scan information displays only if the mobile device supports MSR scanning.</td>
<td></td>
</tr>
</tbody>
</table>
(Realtime) > Session <n> Transaction Displays the number of transactions per <x> seconds for the session, where <n> indicates the session (1–4) and <x> indicates the time set in the Telnet Average Time Display property.

(Realtime) > Session <n> RFID Displays the number of RFID scans per <x> seconds for the session, where <n> indicates the session (1–4) and <x> indicates the time set in the Telnet Average Time Display property.

RFID scan information displays only if the mobile device supports RFID scanning.

Modifying Real-Time Statistics

While many of the emulation session parameters indicate they are changeable, you should only modify RealTimeStatsInterval, Telnet Average Time Total, and Telnet Average Time Display.

To modify a statistic:
1 Launch the Avalanche Console.
2 From the list of mobile devices, right-click the device you want to monitor and select Mobile Device Details.

   The Mobile Device Details dialog box opens.
3 Click the Properties tab.
4 Select the property you want to change and click Edit Property.
5 Type the new value for the property in the dialog box that appears.
6 Click OK.
7 Update the device to send the new property values to the device.

NOTE: If the TE Client is currently running, modified real-time statistics will not display until the next real-time statistics transmission to Avalanche. For example, if you modify the RealTimeStatsInterval property from 300 seconds to 5 seconds, it may wait the remaining seconds of the 300-second interval before the statistics begin to update every five seconds.
Chapter 12: Configuring the TE Client from the Mobile Device

Generally, the TE Client is configured using the configuration utility associated with your installation method. However, you can access certain TE Client parameters from the Client, including:

- Configuring Host Profiles from the Client
- Editing Per-Host Emulation Parameters from the Client

If you make changes in the TE Client configuration from the device, those changes will be overwritten when you download a new TE Client configuration to the mobile device using Microsoft ActiveSync or Avalanche.

Configuring Host Profiles from the Client

You can perform the following configuration tasks using the TE Client interface:

- Accessing Host Profiles from the Client
- Creating a New Host Profile from the Client
- Modifying an Existing Host Profile
- Deleting a Host Profile

Accessing Host Profiles from the Client

To add, modify, or delete host profile, you must access the Host Profiles dialog box.

To access the host profiles dialog box from the Client:

1. On the mobile device, launch the TE Client.

2. Tap Options > Configure > Host Profiles.

   The Input Password dialog box appears.

3. In the Input Host Config Password text box, type the password and click OK.

   **NOTE:** The default password is `system`. For information about modifying this password, see Configuring Passwords on page 143. If no password is configured, the TE Client will not prompt you for a password.

   The Edit Host Profile dialog box appears.

4. Use the Edit Host Profile dialog box to add, modify, or delete host profiles.
Creating a New Host Profile from the Client

You can use the Edit Host Profile dialog box to create a new host profile for the TE Client.

To create a new host profile from the Client:
1 On the mobile device, launch the TE Client.
2 Tap Options > Configure > Host Profiles to access the Edit Host Profiles dialog box.
3 In the Edit Host Profile dialog box, click Add.
   A new Edit Host Profile dialog box appears.
4 Use the Edit Host Profile dialog box to configure the basic parameters of the host profile (alias, emulation type, etc.).
5 Tap Config to access and configure other parameters that are specific to the emulation type.

NOTE: For information about host profile parameters, see Host Profile Configuration Options on page 17.

6 After you have finished configuring the host profile, tap Save in the Edit Host Profile dialog box.
   The Edit Host Profiles dialog box appears, and you are returned to the first Edit Host Profile dialog box, which now displays the new host profile.
7 Tap Done.
   The Edit Host Profile dialog box closes.

Modifying an Existing Host Profile

You can use the Edit Host Profile dialog box to modify the parameters of an existing host profile from the mobile device.

To modify an existing host profile:
1 From the TE Client, tap Options > Configure > Host Profiles to access the Edit Host Profiles dialog box.
2 In the list of profiles in the Edit Host Profile dialog box, select the host profile dialog box that you want to modify.
3 Tap Edit.
4 Use the Edit Host Profile dialog box to modify the basic parameters of the host profile (alias, emulation type, etc.).

5 Tap Config to access and configure other emulation type-specific parameters for the host profiles.

**NOTE:** For more information about the parameters in the Edit Host Profile dialog box and the parameters in the other emulation type-specific dialog boxes, see Host Profile Configuration Options on page 17.

6 After you have modified the parameters for the host profile, tap Save.

   The changes that you have made are applied to the host profile. The Edit Host Profile dialog box closes and you return to the first Edit Host Profile dialog box.

7 Tap Done.

   The Edit Host Profile dialog box closes.

**NOTE:** To exit either of the Edit Host Profile dialog boxes without saving the changes that you have made, press Esc.

**Deleting a Host Profile**

You can use the Edit Host Profile dialog box to delete an existing profile on the mobile device.

To delete an existing host profile:

1 From the TE Client, tap Options > Configure > Host Profiles to access the Edit Host Profiles dialog box.

2 From the list of host profiles in the Edit Host Profile dialog box, select the host profile that you want to delete.

3 Tap Delete.

   The host profile is deleted from the list of host profiles in the Edit Host Profiles dialog box.

4 Tap Done.

   The Edit Host Profile dialog box closes and you return to the primary TE Client interface.

**NOTE:** To exit the Edit Host Profile dialog box without saving the changes that you have made, press Esc.
Editing Per-Host Emulation Parameters from the Client

You can modify certain per-host emulation parameters from the mobile device after the Client has been installed. Parameters available for editing will vary depending on the type of emulation, but may include the following tabs:

• VTXX Settings
• IBM Host Settings
• WEB Settings
• Message Settings
• Font Settings
• Display Settings
• View Settings
• Cursor Settings
• Beeps Settings
• Telnet Settings
• Printer Settings

To access the emulation parameters for a host profile on the device:

1. From the TE Client, click Options > Configure > Emulation.

   The Input Password dialog box appears.

2. In the Input Terminal Config Password text box, type the term config password and tap OK.

   NOTE: The default Term Config password is config. For information about modifying the Term Config password, see Configuring Passwords on page 143. If no password is configured, the TE Client will not prompt you for a password.

   The Select Host dialog box appears.

3. In the Select Host dialog box, select the host profile that contains the emulation parameters that you want to modify and tap OK.

4. Modify the emulation parameters for the host profile.
5  After you have configured the emulation parameters for the host profile, select the **OK** button in the upper right corner of the *Settings* dialog box.

The *Settings* dialog box closes.

**VTXX Settings**

Use the **VTXX** tab in the *Settings* dialog box to configure parameters for VT-type emulation.

The following list describes the parameters in the **VTXX** tab.

- **Local Echo**  
  Indicates whether the TE Client echoes characters that it received from a VT host.

- **Send 8-Bit Control Codes**  
  Indicates whether to use 8-bit ANSI control codes for VT-type emulation.

- **Backspace Sends Delete**  
  Indicates whether the TE Client should send a delete control character when a user presses the backspace key.

**IBM Host Settings**

Use the **IBM Host** tab in the *Settings* dialog box to configure parameters for IBM-type emulation.

The following table describes the configurable options in the **IBM Host** tab.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>5250 - Column Separator Dot</strong></td>
<td>Indicates whether the TE Client displays a period or vertical line between each character when the host system uses a special column format mode.</td>
</tr>
<tr>
<td><strong>5250 Swap Enter Key / Field Exit</strong></td>
<td>Indicates whether the enter key is mapped to the field exit key and the clear key is mapped to the enter key.</td>
</tr>
<tr>
<td><strong>3270 - Alternate System Request</strong></td>
<td>Indicates whether the TE Client encodes 3270 system requests as requests instead of default interrupt processes.</td>
</tr>
</tbody>
</table>

**WEB Settings**

Use the **WEB** tab in the *Settings* dialog box to configure parameters for WEB emulation.

The following table describes the configurable options in the **WEB** tab.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>WEB Allow Compression</strong></td>
<td>Determines whether the browser will automatically decompress any compressed information it receives.</td>
</tr>
</tbody>
</table>
WEB Allow Cookies Indicates whether the web server is able to access cookies on the client.

WEB Automatic SIP Determines whether the SIP keyboard is automatically displayed when the cursor is moved to an edit field.

WEB Default Scanner Auto Keys Determines the default post-scan action for web pages without Tab or Enter key META tags.

Possible Values: <No Keys> <Enter> <Tab> <Enter and Tab>

WEB Default Text Size Indicates whether the default text size should be used when the browser first appears.

Possible Values: <Smallest> <Smaller> <Medium> <Larger> <Largest> <No Change>

WEB Detect Out-Of-Range Indicates whether the TE Client will prevent the user from interacting with a web page if the wireless LAN adapter is not associated with an access point.

WEB Display Images Determines if embedded images and/or placeholders should be displayed on web pages.

WEB Engine Type Indicates the type of web engine that should be used. The Enhanced engine is required to support several advanced features.

Possible Values: <Standard> <Enhanced>

WEB Error 404 Override Determines whether a custom or standard 404 error message is displayed.

WEB Error Messages Determines whether server error messages relayed from the server are displayed.

Message Settings

Use the Message tab of the Settings dialog box to configure the settings for messages that the mobile device receives from the host system. Certain parameters in the Message tab are applicable only to 5250- and 3270-type emulation.

The following list describes the configurable options in the Message tab.
Chapter 12: Configuring the TE Client from the Mobile Device

**Message Line (5250/3270 Only)**
Specifies the line from the host screen that the TE Client reads to display as the message line. The Client displays the message line each time its contents change. When the contents of the message line are not valid, the line appears in reverse video at the top of the display.

**Possible Values:** 0 - 24

**Default:** 24

**NOTE:** Use a value of 0 to prevent the display message.

**Auto Reset Delay (5250/3270 Only)**
Indicates the amount of time (in seconds) the TE Client waits before sending a reset to the host when the **Reset Required** parameter is set to **Never**.

**Possible Values:** 0 - 5 (seconds)

**Default:** 2

**Message Beeps (5250/3270 Only)**
Indicates the number of additional beeps that occur on the mobile device when the TE Client receives a system message.

**Possible Values:** 0 - 255

**Default:** 0

**Reset Required (5250/3270 Only)**
Indicates the situations that require the user to press the reset key.

- **On All Messages.** Requires a reset on screens that display information on line 24 (the bottom display line).
- **On Errors.** Requires a reset on screens that have an error indicator.
- **Never.** Requires a reset, but the TE Client automatically performs the reset when it detects an error indicator.

**Use Enter As Reset**
Indicates whether the enter key on the mobile device functions as the reset key when the mobile device is in an error state.

**Font Settings**
Use the **Font** tab in the **Settings** dialog box to configure the way that text displays for the host connection.

The following list describes the configurable options in the **Font** tab.
Chapter 12: Configuring the TE Client from the Mobile Device

Name
Indicates the font that the TE Client uses to display text in the emulation screen.

Size
Indicates the size (in points) in which text displays in the emulation screens.

Weight
Indicates the weight that is applied to text in the emulation screens.

Left (Clipping)
Indicates the amount of white space (in font points) that the TE Client crops from the left of the character.

**Possible Values**: 0 - 255

Right (Clipping)
Indicates the amount of white space (in font points) that the TE Client crops from the right of the character.

**Possible Values**: 0 - 255

Top (Clipping)
Indicates the amount of white space (in font points) that the TE Client crops from the top of the character.

**Possible Values**: 0 - 255

Bottom (Clipping)
Indicates the amount of white space (in font points) that the TE Client crops from the bottom of the character.

**Possible Values**: 0 - 255

Display Settings

Use the Display tab in the Settings dialog box to configure how the TE Client displays.

The following list describes the configurable options in the Display tab.

**Force Black/White**
Indicates whether the TE Client displays in black and white.

**Menu**
Indicates whether the TE Client displays the TE Client menu during an active session.

**Hide Menu (Button)**
Click this button to access a dialog box that will allow you to configure a key sequence that will hide/reveal the TE Client menu during an active session.

**Hide Menu (Text Box)**
Indicates the key sequence that is configured to hide/reveal the TE Client menu during an active session.

**Vertical Scrollbar**
Indicates whether the TE Client displays the vertical scrollbar during a session.
Chapter 12: Configuring the TE Client from the Mobile Device

**Horizontal Scrollbar**
Indicates whether the TE Client displays the horizontal scrollbar during a session.

**Hide Keyboard (Button)**
Click this button to access a dialog box that will allow you to configure a key sequence that hides/reveals the TE Client emulation keyboard.

**Hide Keyboard (Text Box)**
Indicates the key sequence that is configured to hide/reveal the TE Client emulation keyboard.

**View Settings**

Use the **View** tab in the **Settings** dialog box to configure how the view screen functions for the host connection.

The following list describes the configurable options in the **View** tab.

**Free Cursor**
Indicates whether a user is allowed to move the cursor into “protected” areas of the screen.

**Scrolling (Full Screen Mode)**
Indicates whether the TE Client uses full-screen mode, which allows the user to scroll around the virtual display.

**Scroll Offsets - Vert (Full-Screen Mode Only)**
Specifies the number of columns that the vertical display moves when the cursor crosses the vertical edge of the screen. Use 0 to indicate the current vertical display size.

*Possible Values: 0 - 80*

**Scroll Offsets - Horz (Full-Screen Mode Only)**
Specifies the number of rows that the virtual display moves when the cursor crosses the horizontal edge of the screen. Use 0 to indicate the current vertical display size.

*Possible Values: 0 - 24*

**Fixed Screen Mode**
Indicates whether the TE Client fixes the display on the mobile device to a specific position in the virtual display. When fixed-screen mode is enabled, the same portion of the virtual display appears on the display screen without regard to the location of the cursor.

**NOTE:** If you enable fixed-screen mode, you must also specify the position in the **Fixed Screen Window Origin** group.
Chapter 12: Configuring the TE Client from the Mobile Device

Window Origin - Left (Fixed-Screen Mode Only) Specifies the virtual screen column where the display screen of the mobile device is fixed. Possible Values: 1 - 79

Window Origin - Top (Fixed-Screen Mode Only) Specifies the virtual screen row where the display screen of the mobile device is fixed. Possible Values: 1 - 24

Cursor Settings

Use the Cursor tab in the Settings dialog box to configure the function of the cursor in emulation screens for the host connection.

The following list describes the configurable options in the Cursor tab.

Cursor Edge Zones - Left Specifies the left border of the cursor zone in the virtual display. When the cursor moves outside of the border, the TE Client repositions the screen over the virtual display, centering the cursor on the display screen of the mobile device. Possible Values: Up to 255 Default Value: 4

Cursor Edge Zones - Right Specifies the right border of the cursor zone in the virtual display. When the cursor moves outside of the border, the TE Client repositions the screen over the virtual display, centering the cursor on the display screen of the mobile device. Possible Values: Up to 255 Default Value: 1

Tiling - Vert Mode Determines how the TE Client handles vertical tiling. Options include:

- None. The TE Client repositions the screen on the cursor.
- TopOnly. The TE Client repositions the screen in the uppermost row of tiles.
- All. The TE Client always tiles vertically.

Default Value: <TopOnly>
Tiling - Horz Mode
Determines how the TE Client handles horizontal tiling. Options include:

- **None.** The TE Client positions the screen around the cursor.
- **LeftOnly.** The TE Client positions the screen around the leftmost column of tiles.
- **All.** The TE Client always tiles horizontally.

**Default Value:** <LeftOnly>

Tiling - Vert
Specifies the height of the logical screen in “tiles” for tiling mode.

Tiling - Horz
Specifies the width of the logical screen in “tiles” for tiling mode.

**Beeps Settings**
Use the Beeps tab in the Settings dialog box to configure the beeps that the mobile device plays when it receives messages or errors from the host system.

The following list describes the configurable options in the Beeps tab.

- **Message Beep**
  Indicates the sound that the mobile device generates when it receives a message from the host system.
  
  **Possible Values:** Default, SystemAsterisk, SystemExclamation, SystemExit, SystemHand, SystemQuestion

- **Error Beep**
  Indicates the sound that the mobile device generates when it receives an error from the host system.
  
  **Possible Values:** Default, SystemAsterisk, SystemExclamation, SystemExit, SystemHand, SystemQuestion

- **Silent Mode**
  Indicates whether silent mode is enabled. If silent mode is enabled, the mobile device will not play beeps.

- **Test**
  Tests the beep settings that are configured. The mobile device will play the beeps that are configured for messages and errors, in that order.

**Telnet Settings**
Use the Telnet tab in the Settings dialog box to configure the Telnet auto-connect feature for connections to the host system.

The following option is available on the Telnet tab.
Auto  Indicates whether the mobile device should attempt to reconnect to the host system when the host system terminates the session.

**Printer Settings**

Use the **Printer** tab in the *Settings* dialog box to configure the printer that the mobile device is using for the host connection.

The following list describes the options and configurable parameters in the **Printer** tab.

**Printer**  Indicates the printer that the mobile device uses.

*Possible Values:* PS1000, PS1001, PS1004, LINEPRINTER, DUMB, COMTEC, PATHFINDER, RASCAL, RENEGADE, COMTECL_PS, CODE_COURIER, COMTEC_RF, COMTEC_RF_960, TEC, User Defined

**Port**  Indicates the COM port on the mobile device to which the printer is connected.

**Baud**  Indicates the baud rate of the serial connection to the printer.

*Possible Values:* 9600, 14400, 19200, 38400, 57600, 115200

**Parity**  Indicates the parity of the serial connection to the printer.

*Possible Values:* None, Even, Mark, Odd, Space

**Data**  Indicates the data bits (the number of bits in each octet) of the serial connection to the printer.

*Possible Values:* 4, 5, 6, 7, 8

**Stop**  Indicates the number of stop bits that the serial connection to the printer uses.

*Possible Values:* 1, 2

**Wakeup**  Indicates the string of characters that the mobile device sends to the printer as a wakeup. You can represent the wakeup string as an ASCII or hex value.

- **Hex Value.** Type the hex values of the characters that you want the mobile device to send to the printer. For example, 0000 sends two nulls to the printer.

- **ASCII Value.** Use “<>” to enclose ASCII hex values. For example, <00> <00> sends two nulls to the printer.
Hardware  Indicates whether the serial connection to the printer uses hardware flow control.
Flow Control

Software  Indicates whether the serial connection to the printer uses software flow control.
Flow Control
Common Configuration Tasks

This section provides information about where to locate and configure common parameters for the TE Client, including:

- Configuring Passwords
- Configuring Printing On a Network
- Configuring TE Client Display Settings
- Configuring TE Client Lockdown
- Configuring Key Macros
- Configuring Screen Panning
- Configuring ActiveText
- Configuring Scan Handlers
- Configuring Autologin for VT Emulation
- Configuring Telnet Negotiation Strings for VT Emulation
- Configuring Workstation IDs for 5250/3270 Emulation
- Enabling Battery Strength and Signal Strength Icons

Configuring Passwords

Certain components of the TE Client are password-protected. Users must supply a password to perform the following tasks from the Client:

- Manually configure host profiles
- Manually configure per-host emulation parameters
- Exit the TE Client

**NOTE:** By default, an exit password is not configured. If an exit password is not configured, users are not prompted for a password when they choose to exit the TE Client application.

The following table provides information about and describes where each of these parameters can be configured.
<table>
<thead>
<tr>
<th>Function</th>
<th>Location in Configuration Manager</th>
<th>Parameter Name</th>
<th>Default Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure Host Profiles</td>
<td>Emulation &gt; Common</td>
<td>RF Config Password</td>
<td>SYSTEM</td>
</tr>
<tr>
<td>Configure Per-Host Emulation Parameters</td>
<td>Emulation &gt; Common</td>
<td>Term Config Password</td>
<td>CONFIG</td>
</tr>
<tr>
<td>Exit TE Client</td>
<td>Emulation &gt; Common</td>
<td>Program Exit Password</td>
<td>&lt;None&gt;</td>
</tr>
</tbody>
</table>

To configure a password:

1. Access the Configuration Manager.
2. In the Configuration Manager, locate the password parameter that you want to modify.
3. Use the dialog box for the password parameter to configure the password.

![Program Exit Password]

4. Click OK.
5. Save the configuration and download it to the mobile device.

**NOTE:** For more information about using the Configuration Manager, see Emulation Parameters on page 37.

**Configuring Printing On a Network**

Most mobile devices do not use a printer that is directly connected. Instead, mobile devices print over the network via IP.

Use the Configuration Manager to configure mobile devices for IP printing.

**To configure the TE Client for printing:**

1. Access the Configuration Manager.
2 In the Configuration Manager, double-click the **Emulation > Printing > Printer Protocol** parameter.

3 In the **Printer Protocol** dialog box, select **TCPIP**.

![Printer Protocol dialog box](image)

*Configuring Mobile Devices for IP Printing*

4 Click **OK**.

5 Save the configuration and download it to the mobile device.

**NOTE:** For more information about using the Configuration Manager, see *Emulation Parameters* on page 37.

### Configuring TE Client Display Settings

You can modify and customize TE Client display settings, including:

- Whether the Windows Start menu displays while the TE Client is active.

- Whether the TE Client menu displays while the TE Client is engaged in an emulation session.

- Whether the vertical or horizontal scrollbars display during an active emulation session.

Use the Configuration Manager to customize these (and other) display features of the TE Client.

The following table provides a list of display options and the parameters (in the Configuration Manager) that are used to customize these options.

<table>
<thead>
<tr>
<th>Display Option</th>
<th>Location in the Configuration Manager</th>
<th>Parameter Name</th>
<th>Default Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide Windows Start Menu</td>
<td>Emulation &gt; Display</td>
<td>Hide Start Menu</td>
<td>&lt;Show Standard Start Menu&gt;</td>
</tr>
<tr>
<td>Hide TE Client Menu</td>
<td>Emulation &gt; Display</td>
<td>Hide Menu</td>
<td>&lt;No&gt;</td>
</tr>
<tr>
<td>Display Option</td>
<td>Location in the Configuration Manager</td>
<td>Parameter Name</td>
<td>Default Setting</td>
</tr>
<tr>
<td>---------------------------------------------------</td>
<td>---------------------------------------</td>
<td>----------------</td>
<td>-----------------</td>
</tr>
<tr>
<td>Hide the TE Client Vertical Scrollbar</td>
<td>Emulation &gt; Display</td>
<td>Hide Vertical Scrollbar</td>
<td>&lt;Yes&gt;</td>
</tr>
<tr>
<td>Hide the TE Client Horizontal Scrollbar</td>
<td>Emulation &gt; Display</td>
<td>Hide Horizontal Scrollbar</td>
<td>&lt;Yes&gt;</td>
</tr>
<tr>
<td>Create a Key Sequence to Hide/Reveal the TE Client command bar</td>
<td>Emulation &gt; Display</td>
<td>Menu Toggle Key</td>
<td>&lt;Default&gt; (No key sequence configured)</td>
</tr>
<tr>
<td>Specify the Font that Emulation Uses</td>
<td>Emulation &gt; Display</td>
<td>Font Name</td>
<td>&lt;Standard&gt;</td>
</tr>
<tr>
<td>Specify the Font Size that Emulation Uses</td>
<td>Emulation &gt; Display</td>
<td>Font Size</td>
<td>&lt;7&gt;</td>
</tr>
</tbody>
</table>

To configure a display setting:

1. Access the Configuration Manager.
2. In the Configuration Manager, locate the display option that you want to modify.
3. Use the dialog box for the parameter to configure the display option.
4. Click OK.
5. Save the configuration and download it to the mobile device.

**NOTE:** For more information about using the Configuration Manager, see Emulation Parameters on page 37.

**Configuring TE Client Lockdown**

You can configure several TE Client parameters to effectively lock down the TE Client and prevent users from launching other applications on the mobile device.

**NOTE:** When you configure TE Client lockdown, record your passwords and key sequences in a secure location for administrative purposes. If you forget the passwords that you have configured, you will need to reboot the system and reconfigure the Client.
The following table lists the parameters in the Configuration Manager that you must use to effectively lockdown the TE Client.

<table>
<thead>
<tr>
<th>Parameter to Modify</th>
<th>Location in the Configuration Manager</th>
<th>Parameter Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>WinCE Hide Start Menu</td>
<td>Emulation &gt; Display</td>
<td>&lt;Hide Start Menu&gt;</td>
</tr>
<tr>
<td>WinCE Hide Menu*</td>
<td>Emulation &gt; Display</td>
<td>&lt;Yes&gt;</td>
</tr>
<tr>
<td>WinCE Menu Toggle Key*</td>
<td>Emulation &gt; Display</td>
<td>Do not configure a toggle key (by default, no toggle key is configured)</td>
</tr>
<tr>
<td>RF Config Password</td>
<td>Emulation &gt; Common</td>
<td>Configure a secure password</td>
</tr>
<tr>
<td>Term Config Password</td>
<td>Emulation &gt; Common</td>
<td>Configure a secure password</td>
</tr>
<tr>
<td>Program Exit Password</td>
<td>Emulation &gt; Common</td>
<td>Configure a secure password</td>
</tr>
<tr>
<td>Program Exit Key</td>
<td>Emulation &gt; Common</td>
<td>Configure an exit key</td>
</tr>
</tbody>
</table>

* Hiding and preventing access to the TE Client is not mandatory to locking down the TE Client, but provides an additional layer of security.

To configure TE Client lockdown:
1. Access the Configuration Manager.
2. In the Configuration Manager, modify the lockdown parameters.
3. Save the configuration and download it to the mobile device.

**NOTE:** For more information about using the Configuration Manager, see Emulation Parameters on page 37.

### Configuring Key Macros

Use the Configuration Manager to create, configure, or remove key macros for emulation. Key macros allow you to use a key sequence on the device to send a macro sequence, a different scan code, or perform a local function.

Scan codes for key sequences can be determined from the Diagnostics Utility in the TE Client. Scan codes vary between emulation types, so ensure you use the correct emulation type when obtaining a scan code for a key macro.
The format of a key macro should be:
CODE: [key sequence or \CODE]

Where CODE is the scan code for the key sequence, and everything following the : is the macro. You can use characters or scan codes in the macro.

Examples:

0008:\0020
In this example, pressing the backspace key (0008) will send a space (0020).

0001:username\000Dpassword\000D
In this example, pressing CTRL + A (0001) will send “username” Enter “password” Enter.

To configure a key macro:
1. From the Client, use the Diagnostics Utility to determine the scan code for the keys or key combinations.
2. Access the Configuration Manager.
3. In the Configuration Manager, locate and right-click the Emulation > Common > Key Macro parameter.
   A menu list appears.
4. Select Add to create a new macro or Edit to change an existing macro.
   The Key Macros dialog box appears.
5. Use the Key Macros dialog box to configure the key macro.

6. After you have configured the key macro, click OK.
   The key macro now appears beneath the Key Macros parameter in the Configuration Manager.
7 To delete an existing macro, right-click the macro you want to delete and select Reset.

8 Save the configuration and download it to the mobile device.

**NOTE:** For more information about modifying configuration parameters and using the Configuration Manager, see Emulation Parameters on page 37.

### Configuring Screen Panning

The screen panning feature of the TE Client allows a user to scroll around the screen by tapping and dragging the stylus. By default, screen panning is enabled on the TE Client.

Screen panning has two methods of operation: Standard and Reversed. When screen panning is operating in Standard mode, the view window moves in the same direction as the pen is dragged. For example, the screen will scroll to the upper-left corner of the emulation window as the pen (or mouse cursor) is dragged to the upper-left corner of the screen.

When screen panning is reversed, the view window moves in the opposite direction as the pen is dragged. For example, the screen will scroll to the lower-right corner as the pen is dragged to the upper-left corner. If you want to use reverse screen panning, you must enable standard screen panning.

**To configure screen panning:**

1 Access the Configuration Manager.

2 In the Configuration Manager, locate and right-click **Emulation > Display > Screen Panning**.

   The **Screen Panning** dialog box appears.

3 Use the **Screen Panning** dialog box to enable or disable screen panning for the TE Client.
4 Click OK.

5 If you want to enable/disable reverse screen panning, double-click **Emulation > Display > Screen Panning Reversed** parameters.

The **Screen Panning Reversed** dialog box appears.

6 Use the **Screen Panning Reversed** dialog box to enable or disable reverse screen panning.

7 Click OK.

8 Save the configuration and download it to the mobile device.

### Configuring ActiveText

The ActiveText feature of the TE Client identifies certain strings of text and converts them to objects that a user can select-and-click.

The ActiveText feature can identify two types of strings:

- Simple menu item
- AS/400-style function key

By default, both types of ActiveText are enabled on the TE Client.

The following table indicates the parameters in Configuration Manager that control the different types of ActiveText.

<table>
<thead>
<tr>
<th>ActiveText Type</th>
<th>Configuration Manager Parameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Simple Menu Item</td>
<td>Emulation &gt; Common &gt; Simple Number Menu Active Text</td>
</tr>
<tr>
<td>AS/400-Style Function Key</td>
<td>Emulation &gt; Common &gt; Function Key Active Menu</td>
</tr>
</tbody>
</table>

**To configure ActiveText:**

1 Access the Configuration Manager.
2 In the Configuration Manager, locate and double-click the parameter for the type of ActiveText that you want to configure.

A dialog box for the ActiveText type appears.

3 Use the dialog box to enable or disable the ActiveText.

![Function Key Active Menu]

Configuring ActiveText

4 Click OK.

5 Save the configuration and download it to the mobile device.

**NOTE:** For more information about modifying configuration parameters and using the Configuration Manager, see Emulation Parameters on page 37.

### Configuring Scan Handlers

Scan handlers allow you to define special functions that are applied to the processing of a scan. A scan handler allows you to strip data from the beginning or end of a scan and/or to replace certain characters within a scan.

For information on creating and configuring scan handlers, see the explanation listed on the right panel of the Configuration Manager when you select Scan Handler.

**To add a scan handler:**

1 Access the Configuration Manager.

2 In Configuration Manager, locate and double-click the **Scanner > Common > Scan Handler** parameter.

   The Scan Handler dialog box appears.

3 Use the Scan Handler dialog box to configure a new scan handler.
Configuring a Scan Handler

4 Click OK.

5 The new scan handler now appears beneath the Scan Handler parameter in the Configuration Manager.

6 Save the configuration and download it to the mobile device.

**NOTE:** For more information about modifying configuration parameters and using the Configuration Manager, see Emulation Parameters on page 37.

Configuring Autologin for VT Emulation

You can configure the mobile device to send automatic responses to prompts from a host. This allows for automatic login for VT/HP emulation.

Because autologin is specific to each host system, autologin is configured in the Host Profiles dialog box.

To configure a mobile device for automatic login to a host:

1 Access the Host Profiles dialog box.

2 From the list of host profiles in the Host Profiles dialog box, select the host for which you want to configure autologin parameters.

3 Ensure that you have selected a VT- or HP-type emulation from the Emulation drop-down menu in the Host tab of the Host Profiles dialog box.

4 Select the Autologin tab.

5 Configure the options on the Autologin tab.
Configuring VT Autologin

<table>
<thead>
<tr>
<th>Host</th>
<th>TermProxy 1</th>
<th>Language</th>
<th>VT Settings</th>
</tr>
</thead>
<tbody>
<tr>
<td>Autologin</td>
<td>AutoLaunch</td>
<td>Configuration</td>
<td></td>
</tr>
</tbody>
</table>

**NOTE:** For information about the parameters in the Autologin tab, see Autologin Settings on page 23.

6 After you have configured the Autologin tab, click OK.

7 Download the new configuration to the mobile device.

**Configuring Telnet Negotiation Strings for VT Emulation**

A Telnet negotiation string is used to identify a mobile device to a host system and to present a Client with the appropriate emulation options. Because Telnet negotiation strings are host-specific, they are configured in the Host Profiles dialog box. Telnet negotiation strings are specific to VT/HP emulation types.

To configure a Telnet negotiation string:

1 Access the Host Profiles dialog box.

2 From the list of host profiles in the Host Profiles dialog box, select the host for which you want to configure the Telnet negotiation string.
3 Ensure that you have selected a VT- or HP-type emulation from the Type drop-down list in the Host tab of the Host Profiles dialog box.

4 In the Host Profiles dialog box, select the VT Settings tab.

5 In the Telnet Negotiation String text box, configure the Telnet negotiation string that the mobile device should use when connecting to the host system.

6 Click OK.

7 Download the new configuration to the mobile device.

### Configuring Workstation IDs for 5250/3270 Emulation

The TE Client allows you to dynamically generate a workstation ID for a mobile device using 5250/3270 emulation. Because workstation IDs are specific to each host connection, workstation IDs are configured in the Host Profiles dialog box.

To configure the TE Client to dynamically generate a workstation ID:

1 Access the Host Profiles dialog box.

2 From the list of host profiles in the Host Profiles dialog box, select the host connection for which you want to configure a workstation ID.

3 Ensure that you have selected 5250/3270 emulation from the Type drop-down list in the Host tab.

4 Select the IBM Settings tab.

5 Use the Workstation ID text box to configure the dynamic generation of a workstation ID for mobile devices that use the host profile.
6  Click OK.

7  Download the new configuration to the mobile device.

Enabling Battery Strength and Signal Strength Icons

Battery-strength and wireless signal-strength indicator icons are available in TE Client 5.1 and newer versions. You may configure the following indicator-icon settings:

- Whether to display the signal strength icon
- Whether to display the battery power icon
- Whether to display the icons on the Windows system tray, the TE Client command bar, or elsewhere on the screen
- The size (large or small) of the icons

The following table provides information about configuring the indicator settings to meet your needs:
<table>
<thead>
<tr>
<th>Desired Effect</th>
<th>Parameter in Configuration Manager</th>
<th>Setting</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display icon(s) in Windows task-tray only</td>
<td>Indicators &gt; Indicators</td>
<td>&lt;System Tray Only&gt;</td>
<td>Do not hide the Windows start menu</td>
</tr>
<tr>
<td>Display icon(s) in TE Client command bar only</td>
<td>Indicators &gt; Indicators</td>
<td>&lt;Command Bar Only&gt;</td>
<td>Do not hide the TE Client command bar</td>
</tr>
<tr>
<td>Display icon(s) in TE Client command bar or Windows system tray (whichever is available, starting with the Windows system tray)</td>
<td>Indicators &gt; Indicators</td>
<td>&lt;Command Bar or System Tray&gt;</td>
<td>—</td>
</tr>
<tr>
<td>Display icon(s) on emulation screen (not in the command bar or the system tray)</td>
<td>Indicators &gt; Indicators</td>
<td>&lt;No&gt;</td>
<td>—</td>
</tr>
<tr>
<td>Specify location and size of icons</td>
<td>Indicators &gt; Indicators Screen Settings</td>
<td>Select your preferred option for location and size</td>
<td>Set Indicators Preferred Off-Screen to No</td>
</tr>
</tbody>
</table>

To enable the battery power indicator:

1. Access the Configuration Manager for global emulation parameters.
2. In the Configuration Manager, locate the **Indicators** folder.
3 Use the **Enable Battery Strength Indicator** parameter to enable/disable the battery strength indicator icon.

4 Use the **Enable Signal Strength Indicator** parameter to enable/disable the wireless signal strength indicator.

5 Use the **Indicators Preferred Off-Screen** parameter to configure where the icon(s) are displayed (the Windows system tray, the TE Client command bar, or on the screen itself).

6 If you did not use the **Indicators Preferred Off-Screen** parameter to display icons only in the Windows system tray or TE Client command bar, then use the **Indicators Screen Settings** parameter to configure the location and relative size (large or small) of the indicator icon or icons on the screen.

7 Save the configuration and download it to the mobile device.

**NOTE:** For more information about configuring global emulation parameters, see Emulation Parameters on page 37.